I have a big problem, which prevents me from using Kubuntu 14.04 as my default system. My Asus ul 80 laptop with hybrid graphics (nvidia g210m and intel adapter) seems to use both graphic cards all the time:

$ lspci -vnnn | perl -lne 'print if /^\d+\:.+(\[\S+\:\S+\])/' | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GT218M [GeForce G210M] [10de:0a74] (rev a2) (prog-if 00 [VGA controller])

Can I turn off the nvidia card? I do not want to play with the kubuntu anyway and my laptop is constantly very hot, the fan running a lot and the battery live is only halve compared to win7. So it would be the easiest solution to just turn nvidia off instead of messing around with switching between the two cards(bumblebee etc. which already has lead to great problems and a reinstall). I would really appreciate some help, because until now I am not able to use kubuntu all the time and am afraid it will melt the cpu one day.

Thank you for the hint with the proprietary driver. It saved my kubuntu experience. With nvidia version 340 it works perfectly. Furthermore I figured out there was no option in nvidia x server settings menu to switch between the two shown after installing, but you can do it via terminal:

with prime-select query you can see, which one is currently running.

with sudo prime-select intel you can turn on the intel card.

with sudo prime-select nvidia the other one.

I've been struggling repeatedly on my Asus N55S with an NVidia GT 635M. Especially after the upgrade to Ubuntu 14.04. NVidia is just so evil with the Linux community and its drivers are a well known pain in the neck... Here is what I did:

sudo apt-get install bbswitch-dkms

then

gksudo gedit /etc/modprobe.d/blacklist.conf

and add the following lines

# Blacklist the alternative nvidia module 
blacklist nouveau
# Blacklist the original nvidia module 
blacklist nvidia

then

$ gksudo gedit /etc/modules

and add the following lines

# Switch off discrete GPU 
bbswitch load_state=0

at last update the initial ramdisk by running

$ sudo update-initramfs -u
  • 1
    Worked like a charm with Asus X4GSN and Ubuntu 16.04. – theV0ID Dec 25 '17 at 17:50
  • Does not work with MSI 1060 TI 6g – Nrzonline Sep 2 at 18:56
  • @Nrzonline this answer is for NVidia devices... did you search further? – Andrea Borga Oct 26 at 7:50

There should be such an option in the bios.

Otherwise you can install the proprietary driver and under the nvidia control panel you can select which chipset you want to use. Select the Intel one.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.