0

I have done a clean installation of Ubuntu 14.04.1 LTS in a Toshiba A100 Laptop. However the Wireless card doesn't seem to work out-of-the-box. It does seem to connect to the network but that is it. I can hardly ping my default gateway. Any help would be appreciated. Thank you.

my output of some commands:

lsmod | grep iw

iwl3945                63619  0 
iwlegacy               88016  1 iwl3945
mac80211              546051  2 iwl3945,iwlegacy
cfg80211              409394  3 iwl3945,iwlegacy,mac80211


rfkill list all

0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

dmesg | grep iw

[   11.258665] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, in-tree:s
[   11.258670] iwl3945: Copyright(c) 2003-2011 Intel Corporation
[   11.258733] iwl3945 0000:05:00.0: can't disable ASPM; OS doesn't have ASPM control
[   11.317397] iwl3945 0000:05:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels
[   11.317404] iwl3945 0000:05:00.0: Detected Intel Wireless WiFi Link 3945ABG
[   11.317489] iwl3945 0000:05:00.0: irq 44 for MSI/MSI-X
[   11.518293] ieee80211 phy0: Selected rate control algorithm 'iwl-3945-rs'
[   23.523343] iwl3945 0000:05:00.0: loaded firmware version 15.32.2.9
0

Here is a link to someone with the same problem and the solution that worked: Ubuntu Forums

Copy/paste of the relevant answer:

sudo rm /etc/modprobe.d/ipwraw

sudo rm /etc/modprobe.d/iwl3945

sudo rm /etc/modprobe.d/iwlwifi.conf

sudo gedit /etc/modprobe.d/iwl3945.conf

Add a single line:
Code:
options iwl3945 swcrypto=0
| improve this answer | |
  • Well i tried that and when I rebooted it started connecting to the wireless network and after a few seconds it says disconnected. Tried it a couple of times and same result. – Santi Nov 19 '14 at 14:02
  • I tried adding the lines in /etc/modprobe.d/iwl3945.conf: alias wlan0 iwl3045 and options iwl3945 disable_hw_scan=1 hwcrypto=1 as suggested in another post. However this only got my connection working, but the speed was between 0,5 - 1 Mbps. When its supposed to be aroung 30Mbps via wifi. Any suggestions? – Santi Nov 19 '14 at 15:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.