I have a Canon LIDE 100 scanner that doesn't properly initialize on first scan attempt. When I trigger a scan, it seems to start (you hear the scanner beginning to engage), but then my scanning application (gscan2pdf) echoes back: "Error during device I/O." If I close the application, and restart another scan, there is no error and it scans properly.

I get the same behavior if I use Simple Scan or XSane.

There are many other reports of this behavior, and others have suggested that my system has put the USB port to sleep (at least partially) to save power. It seems to not properly wake up. I'm using 10.10 and it has been suggested that I may be able to tell my system to not autosuspend the USB port, but am not sure how to do that.

Any input on this is appreciated.


Autosuspend of a USB port is possible through the laptop-mode-tools package.

The kernel could also play a part.


If you have this installed then there should be a file called /etc/laptop-mode/conf.d/usb-autosuspend.conf.

Assuming you have this file, examine the file.

Two possible settings you might want to consider:

  1. CONTROL_USB_AUTOSUSPEND="auto" - if you set this to 0 then auto-suspend is switched off for all USB devices.
  2. Perhaps better - you can blacklist certain devices such as your scanner by adding its USB-ID to AUTOSUSPEND_USBID_BLACKLIST. You can find your scanner id by running lsusb. For example - AUTOSUSPEND_USBID_BLACKLIST="046d:c025"

Kernel Boot option

You can force autosuspend to be switched off through the grub-boot option usbcore.autosuspend

Add usbcore.autosuspend=-1 to the value GRUB_CMDLINE_LINUX_DEFAULT in the file /etc/default/grub. Dont forget to run sudo update-grub afterwards.

  • I opted to go with laptop-mode tools, which were not installed on my Thinkpad X201. I installed via Synaptic; however, when I ran cat /proc/sys/vm/laptop_mode, the system came back with "0", indicating that laptop_mode was not eanbled. I then made modifications as described here: help.ubuntu.com/community/PowerManagement/… After rebooting, I'm still getting a "0" when running cat /proc/sys/vm/laptop_mode How do I enable laptop_mode?
    – Kendor
    Jul 31 '11 at 13:10
  • Actually realize that this has nothing to do with getting laptop_mode started... I tried running sudo /usr/sbin/laptop_mode per this manpages.ubuntu.com/manpages/maverick/man8/laptop_mode.8.html and get back this: Laptop mode enabled, not active [unchanged]
    – Kendor
    Jul 31 '11 at 13:55
  • OK, I think I figured out the laptop_mode state issue. Since I'm running under AC power, by default this is inactive. I had to change the config file regarding ENABLE_LAPTOP_MODE_ALWAYS per here manpages.ubuntu.com/manpages/maverick/man8/…
    – Kendor
    Jul 31 '11 at 14:01

I solved my problem for a Fujitsu ScanSnap S1500M under Ubuntu 14.04 Panasonic Laptop following the instructions in


It worked like a charm! I had been looking for a solution for some time!

Two things though (probably since that post is old from 2013):

1) The same "scanbuttond" package file (scanbuttond_0.2.3.cvs20090713-14_i386.deb) is available now in the repositories, probably after installing the cited ppa:rolfbensch/sane-git, so there's no need to download it from the pkgs.com website, just type "sudo apt-get install scanbuttond".

2) The actual button on the scanner does nothing when pressed so I'm not sure what the purpose of the "scanbuttond" software actually is, so probably it is not needed anyway if you don't mind missing this functionality. If the purpose of the software is just to have this physical button work then it doesn't though, at least in my case. I scanned through Easyscan, Xsane and gscan2pdf and all worked perfectly. I would recommend doing the "Scanner config" and "Permissions" sections in the reference article and checking if it works, if it doesn't then go to "Install dependencies" through the PPA and check again. At last I would install the scanbuttond and configure it.

By the way I got it running in a Panasonic Let’s note laptop and there where no usb port power saving issues here. I hope it helps. Good luck!


I was getting the same grief with a Canon MP260 for scanning on an HP Pavilion dm1 running Debian wheezy. Same error report in xsane and gscan2pdf. I had the scanner and some other devices connected via a small USB hub and thence to a USB port on the computer. All the grief disappeared when I moved the printer to connect directly to the computer. Hope that helps somebody.


I solved this problem with my laptop. I have mfp Samsung SCX-4100. When I was trying to scan - message "Error during device I/O" appeared. I created file 'samsung.conf' inside folder /etc/sane.d/ , with text:

# SCSI scanner:
# for the SCX-4100:
scsi "SAMSUNG SCX-4100"
usb 0x04e8 0x3413

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.