0

So here is a summary of what I have been doing today.

  1. Dual booted a laptop (windows 7 64 bit home & ubuntu 14.04); diferent partitions + a data partition.

  2. had to install grub manually (done right)

  3. decided to go back to windows(ubuntu was not for my technologically challenged father)

  4. The MAJOR hiccup: deleted the partition with Ubuntu=> no bootloader

  5. tried reinstalling ubuntu to get grub working again.(failed)

  6. Managed to get a windows repair disk and fixed that

  7. So NOW I realised that the ubuntu installation was done in the data partition.

    windows cannot see the ubuntu partition or the missing data.

I only have a free version of minitool right now, and I realise that I am more of a noob than I thought.

Can anyone please help me recover at least part of the data?

0

First of all if you had all your data in your Ubuntu partition (as I understood) , you said that you formatted it.

Secondly , you noticed that Ubuntu installed in your DATA partition (which formatted all your data in DATA partition). So as I understand you did both the Ubuntu and DATA partitions format.

Thirdly you don't see DATA partition because when you installed Ubuntu probably it changed the type from NTFS to EXT4(or if you have chosen EXT3 or etc.) which Windows won't see by default

Check this http://www.howtogeek.com/112888/3-ways-to-access-your-linux-partitions-from-windows/

So if you want recover your data you could try data recovery tools on Windows maybe it will recover some...

  • To clarify, nothing was formatted (to my knowledge).First install of ubuntu was on a separate 3rd partition which I deleted and doubt it has any effect on the current situation. I merely installed ubuntu(second time) into the data partition by mistake. So from your advice, I used Ext2Fsd to access and searched for the files that were originally in the data partition. The search actually found all the files that were in there. However, I cannot open or copy the files to anywhere else. Is there anyway to do that? – Nirvan Nov 19 '14 at 13:01
  • hmm , I have question , what did you do with first Ubuntu partition after you deleted it and with what tool? – Dambre Nov 19 '14 at 15:15
  • I just deleted the partition using minitool which is how I ran into the grub issue. Then i tried reinstalling ubuntu (mistakenly in the data partition) hoping to get the grub back (could not make that work). I did not realised that I used the data partition until i managed to fix the bootloader using a windows repair disk and the drive disappeared. – Nirvan Nov 19 '14 at 16:28
  • so if you deleted that partition it should be unallocated space. Your grub was on first Ubuntu partition , that is why you got this problem. See this link <askubuntu.com/questions/88384/…> – Dambre Nov 19 '14 at 16:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.