2

I have Ubuntu 14.04 installed on my Lenovo X1 Carbon laptop and since installation I have some strange problems with layout.

Firstly, the default setting for changing layout is not working, it just changes the indicator, so that it states for "En", when really layout is russian. When I manually change language with this indicator, this also have no effect with layouts.

This problem seems to be solved with just running setxkbmap after logging in:

$ setxkbmap -option "grp:caps_toggle,grp_led:scroll,compose:ralt" -layout us,ru

So I mentioned this problem just as I think, it can be linked with the real one.

Secondly, when I attach my laptop to the external keyboard, I have different layouts on these keyboards: if I push the same button on different keyboards, I have different symbols.

And finally and most annoying, when I use IntelliJ IDEA, I can't use any shortcuts, containing letters. And that applies only to internal keyboard. Of course, I tried changing layout multiple times.

How can I fix that?

closed as too broad by user117103, Elder Geek, Tim, Jacob Vlijm, Sparhawk Nov 29 '14 at 5:12

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • You should really split this into three separate questions. – gioele Nov 20 '14 at 15:22
  • @gioele you don't think, they're linked? – Dmitry Ginzburg Nov 20 '14 at 15:23
  • Probably not. Ask separately. – Tim Nov 27 '14 at 13:16
0

If I don't mind the first problem, I may get rid of the second and the third: just turning off any Gnome-based layout features (set one language) and use just setxkbmap.

So, the final solution would be:

  1. Turn off embedded solutions for layout switching and set only one input language (English).
  2. add setxkbmap -option "grp:caps_toggle,grp_led:scroll,compose:ralt" -layout us,ru entry to Menu -> Startup Applications

Not the answer you're looking for? Browse other questions tagged or ask your own question.