7

I wanted to install VLC on Ubuntu, it wasn't working, updated system, than upgraded it, but still it isn't working.

I used both the Ubuntu Software center and the Terminal for that.

In the terminal I typed the command sudo apt-get install vlc

The error message terminal gives me is as follows.

arif@arifpc:~$ sudo apt-get install vlc
[sudo] password for arif: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 vlc : Depends: vlc-nox (= 2.2.0~rc1-1ppa2~trusty) but it is not going to be installed
       Depends: libavcodec56 (>= 7:2.4~) but it is not going to be installed
       Depends: libgles1-mesa (>= 7.8.1) but it is not installable or
                libgles1 but it is not installable
       Depends: libsdl-image1.2 (>= 1.2.10) but it is not installable
       Depends: libsdl1.2debian (>= 1.2.11) but it is not installable
       Depends: libva-drm1 but it is not installable
       Depends: libva-x11-1 (> 1.3.0~) but it is not installable
       Depends: libva1 (> 1.3.0~) but it is not installable
       Depends: libvlccore8 (>= 2.2.0~pre1) but it is not going to be installed
       Depends: libxcb-composite0 but it is not installable
       Depends: libxcb-xv0 (>= 1.2) but it is not installable
       Recommends: vlc-plugin-notify (= 2.2.0~rc1-1ppa2~trusty) but it is not going to be installed
       Recommends: vlc-plugin-samba (= 2.2.0~rc1-1ppa2~trusty) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Note:I'm using Ubuntu 14.04 LTS

6

This happened to me after the upgrade from Ubuntu 14.04 to 14.10.

I found this Solution that helped me.

You need to add the xorg-edgers fresh X crack Repository with this Code in Terminal:

sudo add-apt-repository ppa:xorg-edgers/ppa 
apt-cache policy libgl1-mesa-glx libglapi-mesa

Then Reboot your PC. Then update the repositories with the following commands and install VLC:

sudo apt-get update
sudo apt-get install vlc
| improve this answer | |
  • Or, just the opposite worked for me: sudo apt install ppa-purge, sudo ppa-purge xorg-edgers. – Atcold Mar 31 '17 at 12:01
0

Run the following commands

sudo apt-get -f install

sudo dpkg --configure -a

This should install all missing dependencies and configure dpkg.

| improve this answer | |
  • Thank You Bro, but actually the nearest archieve.ubuntu.com wasn't working, so when i changed it (inside /etc/apt/sources.list) to us.archieve.ubuntu.com, it worked. – Bangash Nov 19 '14 at 20:14
0

Actually I solved this problem the same day, the problem was with the nearest archive.ubuntu.com (Ubuntu Archive Server) I changed all of its instances (13 occurrences in my case) to us.archive.ubuntu.com and it worked. The configuration file where I changed this setting was /etc/apt/sources.list.

Edit: Recently I found another question on askubuntu, the accepted answer to this question is also a nice solution to this problem if you don't want to change the archive.ubuntu address.
Here is that question.

| improve this answer | |
0

By using aptitude i can solve this issue.

source

my topic in UBUNTU.ir community

Solution

sudo apt install aptitude

sudo aptitude install vlc

now you must choose: n

Then terminal will output

Downgrade the following packages:                                          
1)     libgl1-mesa-glx [12.0.6-0ubuntu0.16.04.1 (now) -> 11.2.0-1ubuntu2 (xenial
2)     libglapi-mesa [12.0.6-0ubuntu0.16.04.1 (now) -> 11.2.0-1ubuntu2 (xenial)]

Accept this solution? [Y/n/q/?] y 

Now aptitude downgrades depending packages and install vlc.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.