13

I have heard that Proxy Support in Trasmission has been removed as of version 2.12. Is it possible to use proxy by any other method?

2

TL;DR: http_proxy environment variable works for at least 2.92. For versions 1.4.x and older see configuration options here or below.

Citation from transmission wiki page:

Transmission uses the libcurl library for http- and https-based tracker announces and scrapes. Transmission doesn't support proxies, but libcurl itself honors a handful of environment variables to customize its proxy behavior.

relevant variables start here here. And in CURLOPT_PROXY description there is this:

libcurl respects the proxy environment variables named http_proxy, ftp_proxy, sftp_proxy etc. If set, libcurl will use the specified proxy for that URL scheme. So for a "FTP://" URL, the ftp_proxy is considered. all_proxy is used if no protocol specific proxy was set.

I run transmission-daemon using systemd, so I just add line

Environment=http_proxy=http://proxy_url:proxy_port

to service configuration using

sudo systemctl edit transmission-daemon.service

and all worked.

I have transmission-daemon 2.92. Can't say for sure for older version, but according to this wiki page you should use this parameters for transmission 1.4.x or older:

proxy-authentication String
proxy-authentication-required: Boolean (default = 0)
proxy-port: Number (default = 80)
proxy-server: String
proxy-server-enabled: Boolean (default = 0)
proxy-type: Number (0 = HTTP, 1 = SOCKS4, 2 = SOCKS5, default = 0)
proxy-username: String
-3

Transmission uses the proxy configured using the Network Proxy tool located under the Preferences menu.

Reference Solution

  • 1
    this is not a solution as the feature was removed as of 2.12, and does not state how to accomplish what's asked (fix and I'll remove my downvote). – Tcll Nov 27 '17 at 22:13

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.