After installing Ubuntu 14.04, the connection frequently drops. I tried to fix the problem by myself but I made things worse, I run this code I read in another article which made my connection really slow.

echo "options iwlwifi 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf
sudo modprobe -rfv iwlwifi
sudo modprobe -v iwlwifi

sudo iwconfig wlan0 power off

$ lspci -nn | grep 0280
07:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter [10ec:8179] (rev 01)

Can you help me fix this?


You haven't an iwlwifi device or driver, so it is unlikely that iwlwifi 11n_disable=1 did anything. Please check here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1310512 Notice it is your same 10ec:8179 device. Comment #30, it says:

Tips for RTL8188EE [10ec:8179] and RTL8723BE [10ec:b723] users: those hardware modules have MSI compatibility issue, on some certain platforms they work fine with MSI but break connections without MSI, on some other certain platforms it's opposite. You could try to toggle its module parameter "msi"

Let's try the driver parameter:

sudo -i
echo "options rtl8188ee msi=1"  >  /etc/modprobe.d/rtl8188ee.conf

Reboot and tell us if stability is improved.

  • yes the stability has improved , so the codes i used earlier didn't do anything , should i do something for the speed ? –  Tsakras Nov 18 '14 at 17:17
  • What speeds are you getting and what do you expect? – chili555 Nov 18 '14 at 17:18
  • @Tsakras I will be very glad to help further. Please tell us what speeds are you getting and what you hoped for. – chili555 Nov 18 '14 at 21:32
  • You solved a problem I was facing over a week. Thanks a ton! – gaurav jain Jan 16 '16 at 13:18
  • 1
    @Blauhirn The command I suggested creates it. – chili555 Mar 23 '16 at 22:43

Disabling the n-mode and updating only the kernel to 3.16 did the trick for me.

N-mode: echo "options iwlwifi 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf

Kernel update: How can I install 3.16 kernel on Ubuntu 14.04

  • indeed, updating to 3.16 helped! – MikeD Nov 10 '15 at 16:23
  • This answer is not related to the question about the Realtek adapter at all. – Pilot6 Apr 17 '16 at 21:00

Check to see if the problem persists when downloading a large file. If not, the problem might be http-request-side only, see https://askubuntu.com/a/147385/378854. You might have messed up your namespaces (resolv.conf).

Other than that, reinstalling the wifi driver might work:

sudo apt-get install --reinstall linux-headers-$(uname -r) linux-headers-generic build-essential dkms git 
git clone https://github.com/pvaret/rtl8192cu-fixes.git
sudo dkms add ./rtl8192cu-fixes
sudo dkms install 8192cu/1.9
echo "blacklist rtl8192cu" | sudo tee -a /etc/modprobe.d/blacklist.conf

As of April 2016, the needed install cmd is 8192cu/1.10 (just check the latest version)

Or you might update your kernel manually to a newer version (not really difficult)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.