2

I recently got a new notebook (Acer Aspire V5 573G) with a Nvidia Geforce GTX 850M and the Intel Haswell integrated graphics. Now I read through a lot of websites in order to find out what the best way is to get the system running. Usually, I wont need the GeForce card so that the intel one is good enough. However, I think the Displayport and the HDMI port are wired to the Nvidia card, so I need that one to work as well. Problem is, the Nvidia card is not detected by Ubuntu: Output of lshw -C display:

*-display
       description: VGA compatible controller
       product: Haswell-ULT Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 0b
       width: 64 bits
       clock: 33MHz
       capabilities: vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:65 memory:b3000000-b33fffff memory:c0000000-cfffffff ioport:5000(Größe=64)

The best thing for me would be, that the Nvidia card is constantly turned off but can be activated so that i can use HDMI/Displayport. I already tried to install bumblebee, but -of course- the card is not detected. Please tell me if you need any further information. Thanks a lot!

EDIT: Output of uname -a: Linux LappII 3.13.0-52-generic #86-Ubuntu SMP Mon May 4 04:32:59 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

  • Are you using 14.10 or 14.04? Cause I have been facing some problems with optimus technology and 14.10. – Blenderudit Nov 18 '14 at 16:50
  • I am using 14.04. – Merlin1896 Nov 18 '14 at 17:17
  • Have you tried to see in the bios? Maybe your nvidia card is disabled. – Blenderudit Nov 18 '14 at 18:16
  • It works well under Windows 8.1, so this is also not the case. – Merlin1896 Nov 18 '14 at 18:42
  • what is the output of lspci | grep -i vga – astrob0t Nov 18 '14 at 21:00
2
+50

I think the problem is that current version of Nvidia drivers in Ubuntu does not support this card. You can try to install a newer version. Run in terminal.

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-346
sudo add-apt-repository -r ppa:xorg-edgers/ppa

Also it makes sense to upgrade kernel and graphical stack to HWE of 14.04.2. It can be done by running:

sudo apt-get install --install-recommends linux-generic-lts-utopic xserver-xorg-lts-utopic libqt5gui5 libgles1-mesa-lts-utopic libgles2-mesa-lts-utopic libgl1-mesa-glx-lts-utopic libgl1-mesa-glx-lts-utopic:i386 libglapi-mesa-lts-utopic:i386 libegl1-mesa-drivers-lts-utopic

Then reboot.

After that try both 346 and 349 drivers. New kernel and stack support newer hardware better.

  • This caused a black screen after boot. I had to purge this driver in order to get my Ubuntu working again. – Merlin1896 May 17 '15 at 19:16
  • Well, it is better that nothing. Try nvidia-349 same way. – Pilot6 May 17 '15 at 19:18
  • And is nvidia-prime installed? – Pilot6 May 17 '15 at 19:21
  • Same result for 349, but the card was listed in lshw -C display. As far as I know, nvidia-prime is not installed (how can I check?). – Merlin1896 May 17 '15 at 19:29
  • Just run "sudo apt-get install nvidia-prime" – Pilot6 May 17 '15 at 19:29
0

Instead of Bumblebee, you could try nVidia's proprietary drivers, which have been added Optimus support to.

Open the Software & Updates utility, and navigate to the Additional drivers tab. It will take some time to load, after which you'll be presented with a list of drivers known to work with this device. By default, the open source noveau driver will be selected.

Select the driver next in the list, probably something like nvidia-331, and click Apply. After the download and installation of the driver finished, reboot. You can now open the nVidia Control Panel and configure Optimus in the nVidia Prime section.

If the driver doesn't support Optimus or works badly with your graphics card, choose the following one in the list.

  • 1
    This does not work. The list is empty so that I cannot select any driver. Thank you for editing my post and correcting the format! – Merlin1896 Nov 18 '14 at 17:19
0

Based on what you have said in earlier communications on the Question. Nvidia 349 Seems to be working with your Card. You also intend to use Nvidia GPU only when needed.

So I have a Solution for you. I have posted this to my blog a well and got a very positive response from people who used it. So I have compiled a little how to document like below

The official Repository of Ubuntu has only old and dated drivers. I don't use that myself and would suggest you do the same if you want the latest Nvidia Driver without any problems.

Steps:-

1) First step after installing Ubuntu is to install all updates. You may use the software updater or simply run sudo apt-get update && sudo apt-get upgrade

2) Add the Xorg-edgers ppa using

sudo apt-add-repository ppa:xorg-edgers/ppa and then sudo apt-get update

3) Run sudo apt-get upgrade && sudo apt-get dist-upgrade

This is the most Important step. If you miss this you will see a black screen after reboot. Please do this as we are using the xorg-edgers ppa. We need to ensure all packags required for bumblebee and nvidia are taken from the ppa.

4) Now Install bumblebee and Nvidia drivers using

sudo apt-get install bumblebee bumblebee-nvidia primus nvidia-349

5) Add the current user to the bumblebee security group.

sudo gpasswd -a $USER bumblebee

for Ubuntu 15.04 only you need to manually enable to bumblebee daemon using

sudo systemctl enable bumblebeed

6) This will take care of the Installing the required software on your system. We need to configure it.

I can assure you if you followed these steps so far then configuring should be a breeze.

We start by enabling bbswitch and intel i915 Driver.

7) sudo gedit /etc/modules

Ubuntu 15.04 the file is /etc/modules-load.d/modules.conf

add these two lines to it

i915 bbswitch

8) Edit the bumblebee configuration file. sudo gedit /etc/bumblebee/bumblebee.conf

  1. line 22:

Driver=nvidia

  1. line 55:

KernelDriver=nvidia-349

  1. line 58:

LibraryPath=/usr/lib/nvidia-349:/usr/lib32/nvidia-349

  1. line 61:

XorgModulePath=/usr/lib/nvidia-349/xorg,/usr/lib/xorg/modules

In addition to this there is another file that needs to edited.

9) sudo gedit /etc/modprobe.d/bumblebee.conf

Add the below line to end.

blacklist nvidia-349

Now you may reboot. After reboot.

Check using

sudo apt-get install mesa-utils if mesa-utils is not already installed.

primusrun glxinfo | grep OpenGL

This should tell you that nvidia-349.16 driver in use.

Please note that nvidia-349 is the latest driver at the time of writng this. Please check the launchpad page for xorg-edgers ppa an accordingly replace nvidia-349 with the latest version if any.

Let me know if this works for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.