4

Since upgrading from 12.04 to 14.04 I've lost the ability to set custom keyboard shortcuts in Gnome applications such as gedit and meld.

The setting can-change-accels has no effect when enabled using either gconf-editor or dconf-editor. I also tried using the UBUNTU_MENUPROXY=0 gedit command. In gedit, no matter what, I can't set accelerators by hovering over the menus. Manually editing the .config/gedit/accels file has no effect (accelerator is not working), and the file is re-written upon exit of the application (the rewritten file is all-comments). Inside meld, I noticed that you can set the accelerators by hovering, and they work for the duration of the program, but they are persisted nowhere. Upon restart, the old accelerator is in effect. Watching my home dir shows that no configuration files are written when setting the shortcut, neither when exiting the application.

I also tried creating a ~/.gtkrc-2.0 file, no effect. One of the questions I checked out: here

My conclusion so far is that a serious and important feature of Ubuntu 14.04 is malfunctioning beyond repair. I'm only using LT releases but am consistently dissapointed by the fragility of desktop features.

Note: I'm using gnome flashback - metacity login. I never liked Unity because of the inefficiency of the launcher and panels (classic panels are all I need), plus, the left-side button bar makes me think I'm using a phone or a tablet, which I'm not. A second reason is compiz, which was always buggy (memory leaks, overnight crashes), and the reason I upgraded in the first place.

  • 1
    I know how it feels, upgrading is great when it works but I've hit too many mysterious issues like this which get triggered by the upgrade process, and then you're stuck. Now I go with fresh installs and migrate the settings I care about: takes a little time upfront, but clean system and no bad surprises guaranteed... – lemonsqueeze Nov 24 '14 at 16:23
  • Do you suggest a fresh install might fix this? Normally I also prefer fresh install but haven't had the time for one yet. – haelix Nov 26 '14 at 11:22
  • 1
    Try booting from the 14.04 live usb (without installing) and see if you can replicate the issue. If you can't then this means it was caused by the upgrade process, and a fresh install will make it go away. – lemonsqueeze Nov 26 '14 at 12:31
0

What version of gnome-shell are you using?

gnome-shell --version

Upgrading to version 3.12 has solved the problem for others -

sudo add-apt-repository ppa:gnome3-team/gnome3-staging

sudo apt-get update

sudo apt-get dist-upgrade

sudo apt-get install gnome-shell ubuntu-gnome-desktop

In case it doesn't work, you can go back to version 3.10 -

sudo apt-get install ppa-purge

sudo ppa-purge ppa:gnome3-team/gnome3-staging

| improve this answer | |
  • I actually don't have gnome-shell installed. I have gnome-session 3.9.90 and gnome-session-fallback and gnome-session-flashback, both version 1:3.8.0. – haelix Nov 25 '14 at 11:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.