3

I made a really big mistake and no other articles seem to be fixing this. I was trying to fix my new Ubuntu laptop that I bought because it has the username defualt (spelled wrong) and I didn't like the terminal showing defualt@defualtHP. I think I was able to change it to rootMLR@MLR. I did this from pressing Ctrl+Alt+F1 and using commands I looked up. Then I stupidly entered "startx". Now I can't log in as rootMLR.

So far I have tried:

  1. chown rootMLR:defualt .Xauthority The output for ls -lah is now:

     -rw------- 1 rootMLR defualt 0 Nov  00:46 .Xauthority
    

    If i try chown rootMLR:rootMLR .Xauthority it says invalid group.

    How can I tell what I should put in the chown command?

    But when I reboot, I still am stuck in a log in loop.

    After the reboot when I try chown rootMLR:defualt .Xauthority it says cannot access '.Xauthority' No such file or directory.

  2. I tried deleting it with rm /home/rootMLR/.Xauthority and then rebooting but it doesn't work.

This is all because I stupidly did startx from the Ctrl+Alt+F1 windows.

I'm not attached to this at all yet; is there a way to restore factory defaults or even delete a user all together or something? Or restore the entire operating system to default? I don't have a boot disk or anything for this unfortunately. I can't believe it was working fine and I messed it up; this is very frustrating.

Any help would be immensely appreciated. I need this PC for a project for work and I spent a lot of money on it. I am a super-noob, I need command-by-command instructions if possible. I use Red Hat at work and I really want to start using Linux at home but now I'm very worried that I will not be able to fix this.

  • It's 14.04 version 32 bit. If there's any other information that can help me get an answer, I'll provide it. I've been up for hours trying to fix this. – Mike_lr Nov 18 '14 at 6:16
  • It is very difficult to help without knowing what you did to "fix the name" exactly (and BTW that was not quite right because you have not changed the group. What about creating another administrative user from command line, see askubuntu.com/questions/70236/… and then deleting the users with the mess and then starting anew? See also askubuntu.com/questions/7477/… – Rmano Nov 18 '14 at 8:53
  • What group do you see when you login as rootMLR in Ctrl+Alt+F1 and type id ? – Abey Nov 18 '14 at 10:48
0

You could maybe enter this from dropshell:

 linux64
 grub-install
 update-grub
 update-grub2
 efibootmgr

and then from tty enter this:

 sudo apt-get update
 sudo apt-get install --reinstall ubuntu-desktop

and then enter in tty:

 sudo apt-get upgrade
 reboot

and it might work fine this way.

0

Just been though all this after splitting my system between an SSD and HDD for my user data and couldn't get back in from the desktop.

The problem occurs because when you copy, generally you use root and thus it becomes the owner, which results in your login not being accepted in silence (rather than it beeping which is the case if the login name is wrong).All your settings are no longer available to the desktop through ownership conflicts

I fixed it as follows : Check with ls -l /home/username

  1. sudo su to drop to root

  2. cd /home

  3. chown -R username:username username

  4. chmod -R 755

  5. mount -a or reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.