0

I've checked other and older solutions around the web for wireless issues on Ubuntu 14.04 and a couple solutions here. My problem appears to be either unique or a fluke.

I can connect to the wireless network at home, no problem. But when I'm at school, I can only see available networks -- I cannot connect to them. I open the Network settings, pick a network and try to "Connect" or even use the "Settings" option. Clicking neither button does anything at all. No pop-ups, no windows, no prompts for password. I click and nothing happens. I can see all the available networks, their signal strength, and whether they're secure. I cannot connect to them.

I tried rebooting. I tried downloading various updated drivers via Terminal. This problem only happens at school. I am typing this message at home, connected wirelessly to my router. No issues. It's worth noting I can run Windows at school and connect to the wireless network. School primarily uses Macs, so I don't know if that makes a difference with the routers they're using.

My computer info: Toshiba Laptop -- I'm running Windows 7 64 bit and Ubuntu 14.04 64 bit (full OSes) on this laptop.

I ran the wireless script suggested here from home. The results: http://pastebin.ubuntu.com/9065947/

UPDATE: Wireless data from the location where I can't connect: http://paste.ubuntu.com/9336368/

All help appreciated. Thanks.

EDITED: Corrections.

  • Are you trying to connect via IPV6? If not, set IPV6 to ignore. You also have some pretty strong signals nearby that overpower yours. – ubfan1 Nov 18 '14 at 5:35
  • This is your home network (which we know does work) Can you run the same script at school and post it too? (the bare minimum we need from there is sudo iwlist wlan0 scan) – Fabby Nov 18 '14 at 5:45
  • Good idea @Fabby I'll run the script tomorrow at school and post the results. Thanks. – Proto Nov 19 '14 at 0:12
  • @Fabby : So I couldn't get the script to just run without being connected to the internet. When I found the script all I had to do was download it and then it automatically did everything else. I tried running it from the command line, but no luck. How do I run that script from the command line? Also, sorry it took a few days to get back to this. Crazy week and I had to just give up on Ubuntu for the time being. – Proto Nov 22 '14 at 23:42
  • 1
    @Fabby : Well thats all the options I have. No site is allowing me to paste 1000 lines of text. The dropbox link is it. – Proto Dec 1 '14 at 23:55
2

I have an answer, but I'm still not sure why this was even a problem. Please see the original post for a detailed description of the precise problem.

In the end instead of connecting from the Network panel as usual, I typed in the command:

nmcli d wifi connect YOUR_NETWORK password YOUR_NETWORK_PASSWORD iface wlan0

The command line was the only option for me. I'm actually surprised no one suggested this simple step, but here it is for posterity! Thanks to everyone who pitched in and clued me in to where to look for issues.

0

Your wireless device is not the Atheros; it is:

Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter

You have a conflicting Broadcom driver loaded that may be conflicting. Let's remove it. Please open a terminal and run:

sudo apt-get purge bcmwl-kernel-source
sudo modprobe -r wl

Any improvement? It may take a reboot.

  • Thank you for replying! Sorry I mixed up the Ethernet card with the Wireless. The ethernet is Atheros. I believe the command I typed to check it was 'sudo lspci -v'. I'm rebooting, but I won't know if this worked until tomorrow when I'm in class (it's the only place the wireless won't work). – Proto Nov 18 '14 at 23:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.