0

Okay, I messed my ubuntu 14.04 for the third time, first two times resulting in a complete reinstall since the issues were not solvable, so as you can imagine, starting to get a little frustrated, even though it-s mostly my fault. Writing this from the live ubuntu dvd. I will try to provide as much description as possible, because I am hoping that this can somehow be solved. I am new to ubuntu, so try to be gentle.

WHAT I DID

After installing ubuntu 14.04 on my pc, I was using the open source generic drivers for my ATI HD6570. Then after I while wanted a bigger resolution so I installed fglrx proprietary ATI drivers using the System Settings>Software Updates>Additional Drivers(strictly in that way with not using of terminal or anything) That worked with a flaw, the flaw being a memory leak that grows days slowly until you need to restart pc. Eventually, I wanted to attempt ATI catalyst 14.9 for my GPU (downloaded it from official site) because apparently it lessens the issue. This is where I probably screwed something up. Tried to remove old fglrx drivers through terminal had partial success and I continue to install Ati catalyst using the built/in installer of AMD.

RESULT

When I boot ubuntu it comes to the desktop with only the generic background screen, no icons, no unity tab, no upper tab and nothing else besides background and cursor. Please tell me if this is solvable or should I go and install ubuntu again from the scratch for the third time... sad face

0

Press ctrl+alt+F1 to enter tty1 console and login.

Run the following commands

sudo apt-get remove --purge fglrx fglrx-amdcccle fglrx-dev

sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon

sudo apt-get install xserver-xorg-video-ati

sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

sudo rm -rf /etc/ati

| improve this answer | |
  • It seems it worked HOWEVER: at command number 4 I get the following (even though initially it seems its working): warning: forcing reinstallation of alternative /usr/lib/x86_64-linux-gnu/mesa/ld.so.conf because link group x86_64-linux-gnu-g1-conf is broken ALSO: at step 5 I get: it keeps saying not found. what are these 2 issues and should I worry about it? ALso, is it now safe to try install proprietary drivers without issues? – TribalUbuntu Nov 17 '14 at 19:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.