7

I want to be able to "open in terminal" from any directory.

I have the nautilus-open-terminal package installed

I'm not sure what the problem is exactly: when there's only a couple of items in a directory I can just right-click in the empty space, see the context menu, and click "Open in Terminal".

But if there's enough items to create a scroll bar there's nowhere to right click for the current directory.

If I right click on the breadcrumbs I don't see "open in terminal". The same happens when I look at the "File" menu.

This means that if there's a scrollbar there's no way to open a terminal in the current directory - I need to go up a directory, find the directory I was just in, and right click on that to open a terminal.

If there's no way around this it would be just as good to have a key combo to open a terminal in the current directory (ctrl-alt-t opens a terminal in my home directory).

Thanks for your help!

edit: I'm using list view

2
  • did my answer solved your problem? if yes please accept, if not please let me know the problem Jun 29, 2018 at 9:50
  • @edwardtorvalds it's not very convenient, and the 'menu' key in your image doesn't work for me - I have to use shift-f10. Swapping from mouse to keyboard and back to mouse isn't efficient. In Nautilus 3.26 there's an 'icon view' icon in the menu bar, so I toggle using that, right click in an empty space, then switch back to list view when I'm done.
    – david_nash
    Jul 8, 2018 at 22:32

3 Answers 3

3

Go to the directory where you want to open in terminal. Make sure your cursor in inside in window (where files are displayed). If a file is selected, press the Ctrl + Space to deselect it. Then press Option key.

Keyboard with the option key highlighted

Then context menu pops up. Now you can select the open in terminal option.

13
  • He's probably using list view where it's hard not to have a file selected when the view is full
    – doug
    Nov 17, 2014 at 0:49
  • 1
    @david_nash i reported to canonical. we cant do any thing in this matter. better using icon view Nov 19, 2014 at 3:02
  • 3
    I don't have that keyboard key.
    – Laurent
    Feb 9, 2016 at 4:42
  • 4
    @Laurent Me too. Just use Shift+F10 instead.
    – user502144
    Aug 1, 2017 at 13:10
  • 6
    If a file is already selected try to use Ctrl+Space. I don't know if it is a universal solution, but it works for me in Ubuntu 17.04.
    – user502144
    Aug 1, 2017 at 13:39
2

I know, this is not a real answer to the question.
But it is an alternative to achieve what OP requests as Nautilus does not natively offer a solution:

Use Nemo.

There you can add a button in the Toolbar to open Terminal in current folder.

enter image description here

More on Nemo:

0

The issue boils down to not having empty space where you can right-click with your mouse without touching a file or directory, so, you have to make some space, an easy way is to change the view from list to grid, in the grid view you have plenty of empty space just for you :) On the following page, you see an image, on the left side you have the grid view, on the right side, you have the list view. To toggle between them you have a button on the top right corner (it also appears in both pictures of the link above).

1
  • You've correctly identified the issue but I'm not toggling views back and forth every time I want to open a terminal. I use Nemo now. It has a small terminal icon always visible, and works well for me.
    – david_nash
    Mar 26, 2020 at 20:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.