3

New to Ubuntu/Linux. In Startup Applications, changes are not saved; as soon as I close Startup Applications, settings revert to default. I've searched for answers (and tons of other questions on this site) but have yet to find a solution. Tried adding symbolic links to /etc/xdg/autostart, but it hasn't helped (though the symlinks did save there).

Specifically, I want a desktop slideshow app to start automatically. Using applications GUI's to add to autostart also has not worked. I've tried Wallch, Variety, and Slidewall. Wallch and Slidewall GUI's showed that the programs were set to start with login, but they did not (I also made sure not to run them simultaneously to prevent conflict). The setting kept in the GUI, but it had no effect. When I enable that setting on Variety, the app crashes.

Found another question here that recommended using gnome-session-properties via terminal to edit it instead of launching Startup Apps from Dash, but this is was also ineffective. Terminal provided the following:

** (gnome-session-properties:2319): WARNING **: Could not save /home/jordan/.config/autostart/variety.desktop file

Logging out/restarting also had no effect.

I have also tried adding other apps to startup just to see if the problem was the apps I was using; all attempts have been equally unsuccessful.

4

I figured it out with the help of a number of random threads/questions around this site and the web with different but related issues.

  1. Enter the following in the terminal (without quotes, and with your username):

    sudo chown "yourusername":"yourusername" -R ~/.config
    

    Use of sudo will prompt you for your password. Enter it (the terminal won't show anything while you do), then press Enter. Doing this grants permission to edit the ~/.config directory.

  2. Enter the following in the terminal:

    sudo rm -r ~/.config/autostart
    

    Doing this first grants permission to, then removes the contents of the directory. Initially I tried running without sudo, but I was denied access and told Directory not empty.

  3. Enter the following in the terminal:

    rmdir -r ~/.config/autostart
    

    Doing this removes the directory. If access is denied, try adding sudo before the command as in the previous steps.

  4. Enter the following in the terminal:

    mkdir ~/.config/autostart
    

    Doing this recreates the directory you just deleted, only now you should have full permission over it. If access is denied, try adding sudo before the command as in the previous steps.

  5. Use Startup Applications (in the Dash) or gnome-session-properties (in the terminal) to add an application to the startup applications.

Feel free to comment and correct me if I'm mistaken about anything. This is my (EXTREMELY LIMITED) understanding of what is accomplished by this process. Following these steps, I have had no problems adding/editing/removing applications using Startup Applications via the Dash or gnome-session-properties from the terminal. I have logged out and restarted, and the settings hold.

1

The follwing command will be able to help you: (press Ctrl+Alt+T first) :)

gksudo  gnome-session-properties

using this method, the gnome session properties will appear normally.
After your edit, it will now save your edits.

  • please review my edits, you will be able to learn a few tricks! ;-) – Fabby Dec 19 '14 at 11:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.