2

When the system is quite busy I see that iBus switches layout with noticeable delay. I switch the layout, begin typing (in GEdit, for instance) and I have the beginning of the word in previous locale and the ending in newly switched locale. Maybe this is subjective but in Qt apps this is more noticeable (Skype, GoldenDict).

Is it possible to fix or iBus input method is broken by design? Thanks.

1

I expect that as the X will wait for ibus-daemon reply, which adds another delay layer to input.

  • May be the best is to renice it for some periods or use nice permanently.
  • Or change the delay 400 declared in /etc/dconf/db/ibus.d/00-upstream-settings

    Global Settings:

    1. Create new file: /etc/dconf/db/ibus.d/01-my-settings contains:

      [desktop/ibus/general]
      switcher-delay-time=150
      
    2. dconf update
      

    Single User settings:

    dconf write /desktop/ibus/general/switcher-delay-time 150
    

    Use dconf-editor if you are looking for GUI tool.

| improve this answer | |
  • 1
    The /etc/dconf/db/ibus.d/00-upstream-settings says also to do dconf update in it's comments. Thank you for the tip. Will check that! – igorp1024 Jun 30 '16 at 15:25
  • 1
    @igorp1024, right I missed that. Updated the answer. – user.dz Jun 30 '16 at 15:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.