0

while installing Ubuntu, I choose the first option(erase disk and install Ubuntu). After the installation is complete I reboot my machine and what I got is a purple screen (I think the purple color is because of grub). I have tried to repair grub too still i got nothing. Please help to to tackle this situation...! Thank you

Let me explain this precisely..

First GRUB ask me to choose one of the following option

1)ubuntu

2)advance options for ubuntu

when i click on ubuntu ...it takes me to nothing but just a blank screen and when i click on advance options. it gives me further two more options

1)ubuntu-generic

2)ubuntu generic-recovery mode

when i click on first option it says

Loading Linux 3.8.0 -19-generic

Loading initial ramdisk...

and it gets stuck at this point on clicking the second option it process for a while after that it says

Gave up waiting for root device. Common problems

-Boot args(cat/proc/cmdline)

-check rootdelay

check root

-Missing modules (cat/proc/modules; ls /dev)

then a alert message.....and then Dropping to shell

and then it takes me to initramfs

(initramfs) _

1

Can you boot your computer to the live CD/DVD? If so, and if the computer appears to work correctly booted to the CD/DVD then open Disk Utility from that CD/DVD and check to see if the hard disk is healthy.

It has been my experience that when people install Ubuntu on old computers and have problems, the cause very often is that the hard drive is sick.

On the other hand, if you cannot make your computer work correctly even running Ubuntu from the live CD/DVD, it could just mean that your computer simply isn't particularly compatible with Ubuntu. I run into that occasionally.

| improve this answer | |
  • thank you for replying....the assessment says disk is ok, 5 bad sectors. Is this a good news or bad? – Siddhant Nov 15 '14 at 7:55
  • I have edited my question,maybe now the problem is more understandable ... – Siddhant Nov 15 '14 at 10:32
  • And ubuntu is working fine via live CD – Siddhant Nov 15 '14 at 10:35
  • It sounds to me as though the problem is probably_not your hard drive, but it may be too soon to rule it out. If the computer runs properly from the CD but not from the hard drive, there appears to only be to logical choices: (1) The installation failed (I've seen this before but only when the cdrom drive it installed from was irratic, which is apparently not the case here) or (2) the hard drive is dying. Most hard drives automatically remap dying sectors, so if yours has five sectors waiting to be remapped that might mean the drive is dying faster than it can remap. – gyropyge Nov 16 '14 at 9:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.