-1

I'm certain that I correctly installed Elementary Luna OS alongside Vista, but my computer doesn't seem to recognize it.

There is no dual boot menu, and when I press F12 or F8 during start up, I can't find any option for Luna.

The advanced system properties in the Vista control panel doesn't show an option for Luna either.

When I tried Snyper's suggestion, everything seemed to go fine, but I still can't open Luna:

/dev/sda2 on /media/ACER type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)

/dev/sda3 on /media/DATA type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)

/dev/sdb5 on /media/06f44361-143e-4960-9e07-d04b5e9f4646 type ext4 (rw,nosuid,nodev,uhelper=udisks)

/dev/sdb1 on /media/64ECE79BECE76630 type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)

elementary@elementary:~$ sudo mount --bind /dev /media/06f44361-143e-4960-9e07-d04b5e9f4646/dev

elementary@elementary:~$ sudo mount --bind /sys /media/06f44361-143e-4960-9e07-d04b5e9f4646/sys

elementary@elementary:~$ sudo mount --bind /proc /media/06f44361-143e-4960-9e07-d04b5e9f4646/proc

elementary@elementary:~$ sudo chroot /media/06f44361-143e-4960-9e07-d04b5e9f4646

root@elementary:/# grub-install /dev/sdb

Installation finished. No error reported.

root@elementary:/# update-grub

Generating grub.cfg ...

Found linux image: /boot/vmlinuz-3.2.0-51-generic-pae

Found initrd image: /boot/initrd.img-3.2.0-51-generic-pae

done

root@elementary:/# exit

exit

closed as off-topic by karel, Charles Green, Jan, αғsнιη, Eric Carvalho Nov 16 '14 at 12:32

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – karel, Charles Green, Jan, αғsнιη, Eric Carvalho
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Are the two installations on separate drives? – Snyper Nov 15 '14 at 1:16
  • No, I don't think so. I just "installed alongside" vista, which led me to a slider to adjust space. Actually, I don't think so: Luna ate a lot of my space on C (where vista is). – RootFAIL Nov 15 '14 at 1:17
  • 1
    Do you still have the Elementary live media? – Snyper Nov 15 '14 at 1:20
  • 1
    Yes. It's possible that grub (the Luna boot menu) didn't install correctly. If that's the case, we can chroot into the Luna installation from the DVD and install grub properly from there. I'll have an answer typed shortly. – Snyper Nov 15 '14 at 1:22
  • 1
    Not much, I believe. Maybe several kilobytes. – Snyper Nov 15 '14 at 1:24
0

It looks as if GRUB was installed incorrectly. We can chroot into the Luna partition and re-install GRUB rather easily.

Boot into the Luna DVD. When you have done so, open the file manager and, in the list on the left, click on the partition that Luna is installed on. This will mount your partition.

Next, open a terminal and type mount. The line showing your Luna partition should be near the bottom, and will look something like this:

/dev/sda1 on /media/name type ext4 (rw,nodev)

In my example the partition was /dev/sda1 and the mountpoint was /media/name. The actual values, especially for /media/name, will possibly be different.

Now, in the terminal, type

sudo mount --bind /dev /media/name/dev
sudo mount --bind /sys /media/name/sys
sudo mount --bind /proc /media/name/proc

where /media/name is the value we found previously.

This will mount the needed directories from your Luna installation so that we can chroot into it.

In the terminal again, type chroot /media/name. You should now be seeing a root shell prompt (which should end in #).

If you have only one hard drive, type

grub-install /dev/sda (where /dev/sda is the partition name that mount showed us, but do not use the number at the end) And then:

update-grub

This will reinstall GRUB, and update it so that it recognizes Vista. If you have multiple drives, use the value that the mount command we typed earlier gave us, but without the number at the end.

Now we're finished. In the terminal, type exit, which will make you leave the chroot. You may now restart, and hopefully GRUB will be displayed when next you boot.

  • So that still didn't work. Was I supposed to do "grub-install /dev/sdb" or "grub-install /dev/sub update-grub"? The latter gave me an error. – RootFAIL Nov 16 '14 at 0:41
  • 1
    grub-install /dev/sdb and then just update-grub, without the partition name after it. – Snyper Nov 16 '14 at 1:35
  • 1
    There was a formatting error in the answer--I apologize for that. I've changed the answer accordingly. – Snyper Nov 16 '14 at 1:37
  • I really don't know what I'm doing wrong. Do you think I'd have better luck trying to uninstall and start over? I posted my failed terminal log above. – RootFAIL Nov 16 '14 at 4:16
  • 1
    And it still doesn't show when you reboot? The only thing I can think of would be that Luna was installed on a different hard drive and that your motherboard is booting into the Vista one by default, but from what you've said that can't be the case. I guess you could try a re-install, and see if that works. I'm really sorry that I couldn't help you further. – Snyper Nov 16 '14 at 13:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.