0

I am trying to install a secondary OS (OpenSUSE) onto another partition while keeping Trusty. I tried to do it via USB about 7 times now (using unetbootin, some other program that required a repository, and I've tried universal-usb-installer and 7z. All options give me the exact same error "No Repository Found" so the flash drive easily boots the installer but the installer cannot find the os. How can I install the Suse installer onto another partition or install it directly? I know this question isn't based on Ubuntu but /superuser and /unix didn't help and I still have some hope to the much larger community here. Is there an ubuntu program that can install Suse kinda like wubi.exe?

5
  • Is virtualization okay? – Kaz Wolfe Nov 14 '14 at 23:06
  • Whaaat? you mean installing it onto a virtual machine or through a virtual directory? – Nick Bailuc Nov 14 '14 at 23:07
  • Virtual Machine. – Kaz Wolfe Nov 14 '14 at 23:09
  • No i need to install it natively to run a heavy benchmark and test my multiple gpu system with amdconfig – Nick Bailuc Nov 14 '14 at 23:10
  • Okay. That's doable. – Kaz Wolfe Nov 14 '14 at 23:11
0

First off, you want to create a partition for SUSE. Boot into an Ubuntu LiveCD and use GParted. Make it ext2/3/4. Once you are done with that, reboot.

Back in Ubuntu, download the SUSE iso. Run this command as root (su) in a terminal:

 dd if=/path/to/downloaded.iso of=/dev/sdX bs=4M

Replace sdX with the appropriate device identifier for the USB drive. You can usually find this using lsblk. Do not write to a partition on the drive. Write to the drive itself.

Reboot into the USB drive and follow the instructions. When asked where to install SUSE, choose the partition you made earlier.

Once you are done, you will need to re-install Ubuntu's Grub. Details on how to do that are right here.

Answer source

Disclaimer: I am not responsible for anything that goes wrong in this answer. By using this answer, you agree that any errors from using this question is not my fault.

6
  • i used gparted, is that fine (since it just turns the dd command into a gui) – Nick Bailuc Nov 14 '14 at 23:20
  • gParted and DD are very different things. DD copies data. gParted does partition management. – Kaz Wolfe Nov 14 '14 at 23:21
  • ok, ill try this – Nick Bailuc Nov 14 '14 at 23:22
  • ok i did the dd if=/path/to/downloaded.iso of=/dev/sdX bs=4M and the of=/dev/sdb which seemed to write to the drive itself and not the partition just like you said. but now my ubuntu setep is gone, how do i restore that? – Nick Bailuc Nov 15 '14 at 0:40
  • can i still recover all my data or not? – Nick Bailuc Nov 15 '14 at 1:07
0

Test this:

Download image.iso, openSUSE-13.2-DVD-x86_64.iso, suppose in /home/nick/Download

http://software.opensuse.org/132/en

Open a terminal CtrlAltT.

And run:

sudo -i
mv /home/nick/Download/openSUSE-13.2-DVD-x86_64.iso /
gparted

Make you an ext4 partition for /.

/home with different username,and /swap, it can be shared.

Apply the changes and edit /etc/grub.d/40_custom file

nano /etc/grub.d/40_custom

In the file put this content

menuentry "openSUSE 13.2 DVD" {
  set isofile=/openSUSE-13.2-DVD-x86_64.iso
  set root=(hd0,1)
  loopback loop $isofile
  linux (loop)/boot/x86_64/loader/linux install=hd:$isofile
  initrd (loop)/boot/x86_64/loader/initrd
}

The root=(hd0,1) is the ubuntu / partition your iso image on.

hd0,1 = /dev/sda1
hd0,2 = /dev/sda2
hd1,1 = /dev/sdb1
hd1,2 = /dev/sdb2

The isofile is the path to your iso file. It's located on the root of /dev/sda1.

Let's say you have a separate home partition and your iso is at /home/nick/Dowmload/openSUSE-13.2-DVD-x86_64.iso. You would need to change it to:

isofile=/nick/Download/openSUSE-13.2-DVD-x86_64.iso.

Change the x86_64 to i386 if you're using 32 bit.

Ctrl + O, save file. Ctrl + X, close nano.

You need to update grub2 to recognize your new menu entry.

update-grub

Now you can reboot and select the new entry from Grub2.

The DVD will boot up and work just like normal.

The Grub should be installed on the partition / of openSUSE

Upon restart, Ubuntu only appear in the menu, to:

sudo -i
update-grub

The menu will join the openSUSE installed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.