1

Before I tried to upgrade from Ubuntu 14.04 to 14.10, both Firefox and Thunderbird worked properly. I tried to upgrade, but it hung somehow and I had to reboot, (press the reset button, the little one beside the big start button.) It tried to boot into 14.10, but hung after accepting the password. Using an Ubuntu 14.04 LiveCD, I recovered my /home directory to an external HD, then re-installed 14.04 and copied my saved /home directory back to the new /home directory like this:

sudo cp -dRv dev/sdb1/home/* home/ 

sudo was necessary as cp otherwise could not read all of the files

Since then, neither Firefox nor Thunderbird will run.

  • When I click on Firefox in the launcher, it returns, "Your Firefox profile cannot be loaded. It may be missing or inaccessible." The load mouse pointer continues "spinning" for a minute or so, then just returns to a standard pointer. Firefox never opens a window.

  • When I click on Thunderbird in the launcher, it returns, "Thunderbird is already running, but is not responding. To open a new window, you must first close the existing Thunderbird process, or restart your system." The load mouse pointer continues "spinning" for a minute or so, then just returns to a standard pointer. Thunderbird never opens a window.

All other software seems to work properly.

I've checked and the old .mozilla and .thunderbird directories were copied over along with my other files. I've tried changing permissions in both directories and the files in them; no joy. I've tried renaming the .mozilla directory; Firefox creates a new one, but behaves the same way. I recovered my old /etc, /var and /usr directories along with my old /home directory; copying the old /etc directory to the new one did nothing, the old /var directory crashed the system. I tried upgrading to 14.10; Unity seems a little slower, Firefox and Thunderbird behave the same way. I've tried un-installing and re-installing Firefox and Thunderbird using Ubuntu Software Centre; no joy.

For now I'm using Chromuim and reading emails online. This is will do for now, but is sub-optimal. I would be grateful for any help.

UPDATE -- I made a guest account. Firefox and Thunderbird work correctly in that.

  • Sounds like something may not have completely installed. Can you try purging and reinstalling ff/tb and all dependencies? Does apt report anything awry if you try to do this? – Richard Nov 14 '14 at 2:25
  • @Richard Thanks for the suggestion. I tried running the programs from Terminal. Firefox returned, "GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed Error: Access was denied while trying to open files in your profile directory." Thunderbird returned, "GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed" I did try purging and re-installing both programs with apt-get; reading through apt-get's dialogue for all four commands, (two purges and two installs.) I didn't see any warnings or errors. Both programs display the same behaviour as before. – AD_Burrows Nov 14 '14 at 3:23
  • @Richard Apparently somebody else has been having that "GLib-CRITICAL" error. See "Komodo Edit: GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed" – AD_Burrows Nov 14 '14 at 3:32
  • 1
    As richard suggested what happens when you: askubuntu.com/questions/16758/… – jmunsch Nov 14 '14 at 15:50
  • @jmunsch I followed the procedure at askubuntu.com/questions/16758/…, restarted my computer, then re-installed firefox using apt-get. When I then ran Firefox, its behaviour hadn't changed; its response was still, "Your Firefox profile cannot be loaded. It may be missing or inaccessible." – AD_Burrows Nov 15 '14 at 17:49
2

I mistakenly copied my user directories to the top level of my /home partition instead of in my user directory (/home/username/). I re-copied the firefox directories I deleted earlier to the correct location. I lost my bookmarks, but at least everything worked.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.