4

I'm trying to use smbtree to view samba shares on my local network. Several of those shares are hosted on my own server, which I am running all these commands on. I know the shares exist because I can connect to them on my Mac using the "Connect to Server" (Cmd + K) command and entering

smb://name_of_my_samba_server

However, when I run smbtree, I can see other samba shares on the network but not my own. When I run smbtree with the -d3 option the only line of output that has anything to do with my own samba share and the the server it resides on is the following:

added interface eth0 ip=my.ip.address bcast=first.three.octets.of.my.ip.255 netmask=255.255.248.0

My smb.conf file is at the end of this post, but I don't think my problem comes from the configuration file because I have access to the smb.conf of someone running one of the servers that does appear when I run smbtree, and when I used that person's smb.conf as my own my samba shares STILL did not appear. I want to use smbtree because I'm trying to programmatically scrape the metadata for the samba shares on my LAN, and I'm trying to use smbtree to display all of the shares on the network.

EDIT: So I am able to see the shares on my server when I run

smbclient -L my_ip_address

but this still doesn't show up using smbtree. Why would the two programs (smbtree and smbclient) differentiate who they can see?

[global]

# Network Related Options
# -----------------------
    # interfaces to bind to
    interfaces = lo eth0

    # network segments to allow connections from
    hosts allow =  127., 134.173. 

    # socket / performance options (generally, don't touch these)
    socket options = TCP_NODELAY SO_RCVBUF=131072 SO_SNDBUF=131072
    aio read size = 16384
    aio write size = 16384
    use sendfile = true

# Logging Options
# -----------------------
    # logs split per machine
    log file = /var/log/samba/log.%m

    # max 1024KB per log file, then rotate
    max log size = 1024

    log level = 2
    debug timestamp= yes 

# Authentication Options
# -----------------------
    # generally, don't touch any of this.
    security = user
    encrypt passwords = yes
    passdb backend = tdbsam
    map to guest = Bad User
    guest account = nobody

# Filesystem Options
# -----------------------
    # These options correspond to windows file attributes that don't have
    # UNIX equivalents. Instead of ignoring them, we emulate ('map') them.
    map archive = yes
    map hidden = yes
    map read only = yes
    map system = yes
    store dos attributes = yes

# Nice Global Options
# -----------------------
    # makes UNIX dot files look like Windows 'hidden' files.
    hide dot files = yes

    unix extensions = no
# Miscelaneous Options
# -----------------------
    workgroup = MYGROUP
    # no one actually uses wins
    wins support = no
    # this is just a simple file server, no printing
    load printers = no
[Movies]
    path = /home/alex/Movies
    public = yes
    browseable = yes
    guest ok = yes
    fake oplocks = yes

[Ebooks]
    path = /home/alex/Ebooks
    public = yes
        browseable = yes
    guest ok = yes
    fake oplocks = yes

[Software]
    path = /home/alex/Software
    public = yes
        browseable = yes
    guest ok = yes
    fake oplocks = yes

[Music]
    path = /home/alex/Music
    public = yes
        browseable = yes
    guest ok = yes
    fake oplocks = yes
  • any luck? I also have shares that are not listed in smbtree or when I browse the computer from Windows, but if I type in the share name it works anyway – endolith May 1 '16 at 21:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.