I can't use any of my aliases or custom defined variables in bash. The error when I open the terminal is immediately:

: command not found
bash: /home/khaverim7/.bashrc: line 6: syntax error near unexpected token `$'in\r''
'ash: /home/khaverim7/.bashrc: line 6: `case $- in

I may have added/removed a character somewhere in .bashrc when I last used my computer, but I have no idea where. I have tried copying a default .bashrc file and got a more complex error:

: command not found
: command not found
: command not found
: invalid shell option name
: command not found
: command not found
: invalid shell option name
: command not found
: command not found
: command not found
bash: /home/khaverim7/.bashrc: line 32: syntax error near unexpected token `$'in\r''
'ash: /home/khaverim7/.bashrc: line 32: `case "$TERM" in

This is the current version of my .bashrc file which produces the first error above:

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
case $- in
    *i*) ;;
    *) return;;

# don't put duplicate lines or lines starting with space in the history.
# See bash(1) for more options

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# If set, the pattern "**" used in a pathname expansion context will
# match all files and zero or more directories and subdirectories.
#shopt -s globstar

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "${debian_chroot:-}" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color) color_prompt=yes;;

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
    # We have color support; assume it's compliant with Ecma-48
    # (ISO/IEC-6429). (Lack of such support is extremely rare, and such
    # a case would tend to support setf rather than setaf.)

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    alias grep='grep --color=auto'
    alias fgrep='fgrep --color=auto'
    alias egrep='egrep --color=auto'

# some more ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'

# MY CUSTOM ALIASES=====================================
alias lah='ls -lah'

alias fone="adb -d forward tcp:8080 tcp 8080;telnet -e '' 127.0.01 8080"

# MY CUSTOM FUNCTIONS ===================================
# opall: opens all files with supplied filetype in current dir (e.g. opall doc opens all .doc files)
function opall {
    ls -b *.$1 | xargs -n 1 xdg-open

# Add an "alert" alias for long running commands.  Use like so:
#   sleep 10; alert
alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
    . ~/.bash_aliases

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if ! shopt -oq posix; then
  if [ -f /usr/share/bash-completion/bash_completion ]; then
    . /usr/share/bash-completion/bash_completion
  elif [ -f /etc/bash_completion ]; then
    . /etc/bash_completion
  • 1
    Looks like you have Windows line endings (\r\n) instead of Unix line endings (\n). Did you edit those files on Windows at some point of time? Try the dos2unix command to convert. – muru Nov 13 '14 at 21:07
  • You, sir, are a scholar and a gentleman. I don't know how this happened but dos2unix fixed it. – khaverim Nov 13 '14 at 21:18

Looks like you have Windows line endings (\r\n) instead of Unix line endings (\n). For example, look at the first set of error messages:

... token `$'in\r''
'ash: /home/khaverim7/.bashrc: line 6: `case $- in

What it should be, if \r (carriage return, which sends the cursor back to the first character in a line) were printed as \r:

... token `$'in\r''
bash: /home/khaverim7/.bashrc: line 6: `case $- in\r'


: command not found

would be due the lone \r on an empty line:

bash: \r: command not found


: invalid shell option name

would be due to a \r at the end of shopt command, where the option name is short enough:

bash: line 0: shopt: something\r: invalid shell option name

(Compare with bash -c blah and bash -c 'shopt -s blah'.)

To regain Unix line endings, use the dos2unix command to convert:

dos2unix .bashrc

I would suspect that you used a Windows-based client at some point (like WinSCP, FileZilla, etc.), or that your editor has defaulted to Windows line endings.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.