3

So I've been struggling with this issue for a little while and I can't seem to figure it out. I am on a clean install of Ubuntu (meaning I haven't messed about with audio stuff yet), and I am facing the same issue with my Dragonfly USB DAC as I have with other distros. When the volume is below 100%, the sound coming into my headphones through the DAC is barely audible, even when close to 100%. However, if I push the volume over 100% it becomes very audible, too loud in fact.

Is there a known "fix" for this issue? I'm assuming there's some way to get around this since the audio does play through the DAC, the issue is just the large jump from soft to very loud when going over 100% volume. When not using the USB DAC, the audio is as expected. I can comfortably listen at around 30% volume.

Thanks!

3

There is a known fix for this issue, but it does not mention the Dragonfly specifically, so I had a really hard time finding it too.

Basically what you need to do is edit a line in the /etc/pulse/default.pa file.

From:

load-module module-udev-detect

To:

load-module module-udev-detect ignore_dB=1

Then from the command line run:

killall pulseaudio

This should cause pulseaudio to stop and then restart, though I had to reboot my computer to get it work.

I should also mention with this fix, you will hear output on the Dragonfly but will not be able to adjust the volume, until you select it as your output device in under System Settings -> Sound.

Take a look at:

  • Worked for me. Thanks for sharing. I should mention the reboot wasn't necessary for me, in case anyone is wondering. – techdude Apr 9 '15 at 13:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.