29

In my Ubuntu 14.10, I have VLC 2.2.0 installed. I encounter this annoying problem that VLC mutes when I seek forward or backward through a video. I have to do few seeks backward and forward again to get the sound back. This happens almost all the time when I seek using keyboard or mouse. Is this a bug of VLC? or is this something else that I can fix?

Thank you.

6
  • 14
    See if this works: Tools > Preferences > Audio, set Output module to ALSA audio output, then set Device to PulseAudio Sound Server.
    – edwin
    Nov 13, 2014 at 19:57
  • 1
    In my case, output module was set to Automatic. I changed it to PulseAudio and then to ALSA, but no luck.
    – Deepal
    Nov 14, 2014 at 5:24
  • When you changed output module to ALSA, did you set Device to "PulseAudio Sound Server"? (Notice that the Device option is hidden and it's shown when you select ALSA for Output module.)
    – edwin
    Nov 14, 2014 at 11:19
  • Yes. But problem is still there.
    – Deepal
    Nov 14, 2014 at 11:51
  • I confirm this problem on 14.04 and VLC 2.2.1. Happens with mp4 and avi. Maybe other formats too, haven't tried. Stereoclammarks's answer helped, I switched to ALSA output.
    – Highstaker
    May 8, 2015 at 5:51

2 Answers 2

22

I experienced this on two different distributions. The solution was, as suggested above but found experimentally, to switch to "ALSA audio output" module with "Default ALSA Output (currently PulseAudio Sound Server)" device. This worked for both. It changes no functionality since ALSA gets routed through Pulse anyway.

Note you may need to restart VLC after switching the output module and device and make sure there's no lingering instance (reboot to guarantee). Otherwise it's easy to think it didn't work.

3
  • Where am I supposed to switch that? Dec 7, 2016 at 5:14
  • Works like a charm so far. :) @TomášZato Tools menu -> Preferences -> Audio section -> Output module -> ALSA audio output. Mar 6, 2017 at 21:52
  • "Switch to <a> with <b>" doesn't really make sense. :-| Ironically, changing it from "Default ALSA Output (currently PulseAudio Sound Server)" to "PulseAudio Sound Server" seems to have fixed it for me.
    – zaTricky
    Oct 2, 2019 at 22:01
-1

Probably it's just that vlc needs some more time after the seek operation to resync and play audio / video properly.

This can happen with some poorly encoded video files that might be huge or just have incorrect/obsolete structure. Try changing the video file and see if you still face the same behavior.

3
  • Yeah as I said this happens almost all the time I play any video and seek.
    – Deepal
    Nov 14, 2014 at 5:23
  • this might not have been the OP's problem but it happens all the time. I have a video file that took around 15 full seconds to start playing audio again after seek. Dec 13, 2015 at 3:57
  • OP does specifically say it mutes. Not that there is just no audio.
    – zaTricky
    Oct 2, 2019 at 22:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.