0

I installed Ubuntu 14.10 a week ago. Everything was ok except some minor audio problems which I detailed in a previous post.

Currently as far as I can see networking is not working at all - no wireless if I'm on Wi-Fi - no Internet if I'm on cable It also doesn't work in safe mode.

I tried most of the things I have seen on forums at network problems (changing failsafe config, changing networking config, etc). Currently I just left the first 2 lines for network config as described in this question: "waiting for network configuration" Problem

  • Can you tell us which network adapter you're using? Run lspci | grep -i wlan to see the available adapters. – jessenorton Nov 13 '14 at 14:13
  • 1
    How about: lspci -nn | grep 0280 Thanks. – chili555 Nov 13 '14 at 14:27
  • 1
    Let's see if there are any errors in the log when you load the driver: sudo modprobe iwlwifi && dmesg | grep iwl If the output is lengthy, post it here and give us the link: paste.ubuntu.com – chili555 Nov 13 '14 at 14:42
  • 1
    Looks pretty normal so far. How about iwconfig; dmesg | grep wlan. Paste as well, please. – chili555 Nov 13 '14 at 14:58
  • 1
1

It worked after reinstalling resolvoncf, as described in this link: "ping: unknown host google.com" but IP's works fine

sudo apt-get remove --purge resolvconf && sudo apt-get install --reinstall resolvconf

Thanks to @chilli555 for walking me through the first stages of the problem.

  • I see similar issues, but this didn't solve anything. – Andy Nov 21 '14 at 15:10
  • @Andy This is the solution if you are already connected to the network - so if you can check if you are connected to your network first, then if you run this command it should work. – paxRoman Nov 24 '14 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.