0

I know this question has been asked before but my scenario is slightly different.

I'm able to connect to the internet via Firefox and Skype. However all other applications are unable to.

I'm operating behind a school proxy, and I'm running Kubuntu 14.04 (installed last night). I have set up my proxy settings to manual and configured them correctly. I also tried exporting the environment variables but its not working.

On running:

sudo env http_proxy=example.myproxy:3128 apt-get install gimp

I get the error:

Failed to fetch http://archive.ubuntu.com/ubuntu/pool/universe/d/dvgrab/dvgrab_3.5-2_amd64.deb Cannot initiate the connection to 3128:80 (0.0.12.56). - connect (22: Invalid argument).

It's a laptop, and I connect to various networks, so setting the variables to be persistent is not a desirable option.

On WI-FI though all works well (no proxy)

0

That's because you didn't specify the protocol in the http_proxy value. As the output says:

connection to 3128:80 (0.0.12.56)

That's totally different from what you're trying to achieve I assume. It's interpreting example.myproxy as protocol, 3128 as IP address in decimal notation (0.0.12.56 in dotted form) and the default port 80.

Try using this instead if this is a regular HTTP proxy on port 3128 at example.myproxy:

http_proxy='http://example.myproxy:3128/'

Regarding applying settings in KDE or any other desktop environment; please make sure to log out and log back in for settings like this to become effective, as it concerns environment settings which are inherited from parent processes (your KDE login session).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.