I've followed this tutorial on installing aircrack on Ubuntu 14.04: https://www.youtube.com/watch?v=xdvGZlUzfRs&src_vid=OF0UjeoTXoI&feature=iv&annotation_id=annotation_1882595149

I had to tweak a few things to get it to download successfully, but here is what I'm having issues with (and what I can't find a solution for):

This command:

sudo airodump-ng mon0

of which I get the error:

Interface mon0:  
ioctl(SIOCGIFINDEX) failed: No such device

The command iwconfig shows:

eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11abg  ESSID:"nameofmynetwork"  
          Mode:Managed  Frequency:5.765 GHz  Access Point: 05:B1:51:42:A1:5D   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:on

Regarding mon0, what is it? I tried some solutions, such as killing processes and updating to the latest aircrack, but I still receive an error.

Any help is appreciated!

  • 1
    It's conceivable that you have a wireless card that simply can't be put in monitor mode - at least with its Linux drivers. Such cards aren't all that common but they certainly exist. Unfortunately, if you have one, the only thing you can do about it is to replace it.
    – Darael
    Nov 20, 2015 at 12:51
  • hey, could you please mark my answer as valid, @boop? thank you :)
    – Gewure
    Oct 23, 2016 at 12:27

6 Answers 6


you don't need to use airmon-ng at all. you can simply:

sudo ifconfig wlan0 down

than go on with

sudo iwconfig wlan0 mode monitor

and finally

sudo ifconfig wlan0 up

thats basically what airmon-ng does.

  • 2
    It says: Error for wireless request "Set Mode" (8B06) : SET failed on device wlan0 ; Operation not supported.
    – RegarBoy
    Oct 29, 2016 at 14:13
  • 2
    that most likely means that you need to patch your driver - it doesnt support monitor mode. it may also be that your wirelesscard doesnt support monitor-mode hardware-wise - in which case buying an atheros-wifi-stick is the way to go.
    – Gewure
    Oct 29, 2016 at 15:03

You need to read more about how to use aircrack-ng.

The command you executed, sudo airodump-ng mon0, tells your computer to start capturing packets on the interface called mon0, but you don't have that interface yet, that's why it tells you No such device.

The general steps in using aircrack-ng is:

  1. sudo airmon-ng start wlan0

    • This puts your wireless interface into monitor mode, which is the mode where you can capture all packets, even if they weren't directed to your computer. What the command actually does is it creates another interface called mon0, which you can see when you do iwconfig. This is the command that you probably didn't execute. If you did run it but you can't see mon0 afterwards, let us know what was the command's output.
  2. sudo airodump-ng <options> mon0

    • This starts capturing packets.
  3. sudo aireplay-ng <options> mon0

    • You use this to attempt to increase the number of IVs being captured so you can easily crack the password.
  4. sudo aircrack-ng <options> <file>

    • This is the application that then cracks the capture you took to extract the password.
  • Thanks for your reply. The output for sudo airmon-ng start wlan0 is this: pastebin.com/FjPyvcpg
    – boop
    Nov 14, 2014 at 6:16
  • Are you sure that was the command you did? Did you do sudo airmon-ng start wlan0mon? Please give us the complete output of sudo airmon-ng start wlan0; iwconfig.
    – Alaa Ali
    Nov 15, 2014 at 21:35
  • Yeah pretty sure, here's the pastebin image of the output for the command you asked for: pastebin.com/KNHrCXBV
    – boop
    Nov 24, 2014 at 5:21

The problem is with the name of the interface. Use the following commands:

Start your wireless interface in monitoring mode


Kill all the interfering processes

airmon-ng check kill     

Instead of airodump-ng mon0, type this airodump-ng wlan0mon

Please let me know if this works for you.

  • For me it didn't, the same error.
    – RegarBoy
    Oct 29, 2016 at 14:11

From what i've seen, in the latest ubuntu version (15.10) there is a problem when enabling monitor mode on mon0.

To do it clean and clear, use this command to kill any process that can cause problems sudo airmon-ng check kill , then use this command to enable monitor mode on mon0 sudo airmon-ng start wlan0 .

Now you can use mon0 with other *-ng commands.


Okay, first of all let's start with killing all processes with sudo airmon-ng check kill , then enabling monitor mode with sudo airmon-ng start wlan0 , now the answer to your question is in the output of this command. Notice that it says in the bottom (experimental wl monitor mode vif enabled for [phy0]wlan0 on [phy0]prism0) for me it says prism0 this is the interface that was created for me when I used the airmon-ng start wlan0 command which is in general called mon0 but it's not always the same so you need to check the name of the one that was created for you and use it in the next command. For example in my case, to start capturing packets I will type airodump-ng prism0 not mon0. I hope this answers your question.


if airodump-ng mon0 doesnt works for you; give the previous one command as; "airmon-ng start wlp3s0" rather than "airmon-ng start wlan0" because wlan0 works for network on lan and wlp3s0 works for wireless network and then insert command "airodump-ng mon0" this will surely work for you too

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .