5

I have tried many solutions, but bottom bar is still there.

Tried with Tweak Tool but there's no option Remove bottom bar extension in this version. Any help?

OS: Ubuntu 14.04

1

In order to remove bottom panel follow the below steps from Wey on the Arch Linux forums:

  • Edit /usr/share/gnome-shell/theme/gnome-shell.css: Search for #message-tray and comment the block out with /* ... */. This will remove the black bar, but not the icons and their text.
  • Next go to /usr/share/gnome-shell/js/ui/messageTray.js: Search for ICON_SIZE (its in line 881 here) and set it to 0:

    ICON_SIZE: 0,
    

    About three lines below it states

    this.title = title;
    

    Make it

    this.title = '';
    

    This makes the whole thing disappear.

(OR) use yanir's solution from the same thread:

  • Edit /usr/share/gnome-shell/theme/gnome-shell.css: Search for #message-tray and comment the block out with /* ... */. This will remove the black bar, but not the icons and their text.
  • edit /usr/share/gnome-shell/js/ui/messageTray.js the following way: (the last class at the end of the file)

    const SystemNotificationSource = new Lang.Class({
        Name: 'SystemNotificationSource',
        Extends: Source,
        _init: function() {
            this.parent(_("System Information"));
            this._setSummaryIcon(this.createNotificationIcon());
        },
        createNotificationIcon: function() {
    //        return new St.Icon({ icon_name: 'dialog-information',
    //                             icon_type: St.IconType.SYMBOLIC,
    //                             icon_size: this.ICON_SIZE });
            return 0;
        },
        open: function() {
            this.destroy();
        }
    });
    
2

A fantastically neat way to do this, via a Gnome Shell extension and no code hacking, is to install Dash to Dock:

https://extensions.gnome.org/extension/307/dash-to-dock/

You don't have to have its dock enabled.

In the main tab, set:

  • Dock is fixed and always visible to OFF and
  • Autohide and Intellihide to OFF

In the optional tab, set:

  • Make message tray insensitive to mouse events to ON.

Voila!

  • This seems to be a complete replacement for the Gnome extension "Insensitive message tray". Superb! @Marco could you mark this as answer. – domih Feb 9 '16 at 9:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.