Just installed Ubuntu 14.10 on my server, replacing 14.04 (not upgrading it). I gave it the same name (ubuntu-server) as before. I installed Samba and redefined the shares previously established, using the same names: sde, sdf, etc.

However, I can no longer access those shares from Mac OS (Yosemite). I've rebooted the server and the Mac OS systems, to no avail. The server and the shares appear on both of the Macs, but my connection to the server is that of Guest, and although I've enabled Guest access, when I try to access one of the shares, I get a dialog "The operation can't be completed because the original item for "" can't be found". If I try to change the connection to be as a registered user, I get "There was a problem connecting to the server "". Check the server name or ip address and then try again . . .".

Does anyone know what the problem is or what I can check to get further details about what the actual problem is?

Regards, David

migrated from stackoverflow.com Nov 12 '14 at 19:24

This question came from our site for professional and enthusiast programmers.

Had the exact same issue. Try the following:

sudo smbpasswd -a <username> #this should be your home account username on Ubuntu

it should prompt you to set a samba password, which is stored separately to your Ubuntu passwords. You can set it the same as your Home user password if you wish, although it is not recommended. Then do:

sudo nano /etc/samba/smb.conf

Scroll to the bottom of the file and add/edit your shared folders as follows:

[<folder_name>]
path = /home/<user_name>/<folder_name>
available = yes
valid users = <user_name>
read only = no
browseable = yes
public = yes
writable = yes

Then restart samba with:

sudo service smbd restart

last but not least:

testparm

If all is well you should see a message like:

Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section "[printers]"
Processing section "[print$]"
Processing section "[<folder_name>]"
Loaded services file OK.
Server role: ROLE_STANDALONE

Lifted from instructions here.

This worked for me on Mac OS 10.10.1.

  • good point, forgot about that – kalel Dec 14 '14 at 22:40
  • This should be the accepted answer. – Blairg23 Oct 17 '16 at 6:07
  • Setting a samba password as described in this answer allowed me to connect using Cmd + K in Finder window, entering smb://<ip-address> of Ubuntu machine, and adding the new samba user & password in MacOS High Sierra. – Michael Fulton Oct 28 '17 at 18:54
  • This answer should be accepted as right. Let's give credit to whoever earned it. – Almir Campos Jun 9 at 21:31

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.