I'm trying to get X to start on a system with an nvidia ion chipset, but no matter what I do, it fails. This device worked with nvidia as the driver with ubuntu Karmic, so I'm not sure why it's failing.

(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/extra-modules/nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
    compiled for 4.0.2, module version = 1.0.0
    Module class: X.Org Video Driver
(EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
(EE) NVIDIA:     system's kernel log for additional error messages.
(II) UnloadModule: "nvidia"
(II) Unloading /usr/lib/xorg/extra-modules/nvidia_drv.so
(EE) Failed to load module "nvidia" (module-specific error, 0)
(EE) No drivers available.

Fatal server error:
no screens found

dmesg has no useful info regarding it.

I have these packages installed:

# dpkg -l *nvidia* | grep ^ii
ii  nvidia-173                            173.14.22-0ubuntu11                             NVIDIA binary Xorg driver, kernel module and VDPAU library
ii  nvidia-173-modaliases                 173.14.22-0ubuntu11                             Modaliases for the NVIDIA binary X.Org driver
ii  nvidia-180-modaliases                 185.18.36-0ubuntu9                              Transitional package for nvidia-185-modaliases
ii  nvidia-185-kernel-source              195.36.24-0ubuntu1~10.04                        Transitional package for nvidia-glx-185-kernel-source
ii  nvidia-185-libvdpau                   195.36.24-0ubuntu1~10.04                        Transitional package for nvidia-185-libvdpau
ii  nvidia-185-modaliases                 195.36.24-0ubuntu1~10.04                        Transitional package for nvidia-185-modaliases
ii  nvidia-96                             96.43.17-0ubuntu1                               NVIDIA binary Xorg driver, kernel module and VDPAU library
ii  nvidia-96-modaliases                  96.43.17-0ubuntu1                               Modaliases for the NVIDIA binary X.Org driver
ii  nvidia-common                         0.2.23                                          Find obsolete NVIDIA drivers
ii  nvidia-current                        195.36.24-0ubuntu1~10.04                        NVIDIA binary Xorg driver, kernel module and VDPAU library
ii  nvidia-current-modaliases             195.36.24-0ubuntu1~10.04                        Modaliases for the NVIDIA binary X.Org driver
ii  nvidia-glx-173                        173.14.22-0ubuntu11                             Transitional package for nvidia-glx-173
ii  nvidia-glx-180                        185.18.36-0ubuntu9                              Transitional package for nvidia-glx-185
ii  nvidia-glx-185                        195.36.24-0ubuntu1~10.04                        Transitional package for nvidia-glx-185
ii  nvidia-glx-96                         96.43.17-0ubuntu1                               Transitional package for nvidia-glx-96
ii  nvidia-settings                       195.36.08-0ubuntu2                              Tool of configuring the NVIDIA graphics driver

I'm starting X with xinit /usr/bin/lxsession -session NO_WM -- /usr/bin/Xorg :0.0 -dpms -s 0 -v -allowMouseOpenFail -br (The session is a custom one, but others fail too.)

Here's my xorg.conf

Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0

Section "Monitor"
    Identifier   "Monitor0"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"

Section "Device"
    Identifier  "Card0"
    Driver      "nvidia"
    VendorName  "nVidia Corporation"
    BoardName   "Unknown Board"
    BusID       "PCI:2:0:0"

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    SubSection "Display"
        Viewport   0 0
        Depth     24

If I use nvidia-xconfig it produces a config file with the vesa driver, which isn't acceptable for what this box will be used for. I'm at a loss for how to continue.

From some googling, I found advice that suggested to add some modprobe blacklists, which I added; they did not help.

blacklist vga16fb
blacklist nouveau
blacklist rivafb
blacklist nvidiafb
blacklist rivatv

The device, according to lspci is 02:00.0 VGA compatible controller: nVidia Corporation Device 0874 (rev b1)

Loading the modules directly fails:

# modprobe nvidia
FATAL: Module nvidia not found.
# modprobe nvidia-current
FATAL: Module nvidia_current not found.

dkms status says I have it;

# dkms status
nvidia-96, 96.43.17: added 
nvidia-current, 195.36.24, 2.6.32-32-generic, i686: installed 
nvidia-173, 173.14.22: added 

Here's the loaded modules.

# lsmod
Module                  Size  Used by
snd_hda_codec_nvhdmi     3840  1 
snd_hda_codec_realtek   203376  1 
binfmt_misc             6587  1 
ppdev                   5259  0 
snd_hda_intel          22069  0 
snd_hda_codec          74201  3 snd_hda_codec_nvhdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep               5412  1 snd_hda_codec
snd_pcm_oss            35308  0 
snd_mixer_oss          13746  1 snd_pcm_oss
snd_pcm                70694  3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_seq_dummy           1338  0 
snd_seq_oss            26722  0 
snd_seq_midi            4557  0 
snd_rawmidi            19056  1 snd_seq_midi
snd_seq_midi_event      6003  2 snd_seq_oss,snd_seq_midi
snd_seq                47263  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              19098  2 snd_pcm,snd_seq
snd_seq_device          5700  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
video                  17375  0 
output                  1871  1 video
snd                    54244  12 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
lp                      7028  0 
psmouse                63677  0 
serio_raw               3978  0 
shpchp                 28835  0 
i2c_nforce2             5199  0 
soundcore               6620  1 snd
snd_page_alloc          7076  2 snd_hda_intel,snd_pcm
parport                32635  2 ppdev,lp
usbhid                 36110  0 
hid                    67288  1 usbhid
r8169                  34140  0 
mii                     4381  1 r8169
ahci                   32360  2 
  • You could try 11.04 it has better support for newer computers... – Alvar Sep 30 '11 at 20:01
  • @Alver: Lucid is an LTS release, and 11.04 isn't. I need it to be LTS. I'll revisit this with 12.04 at some point – Daenyth Oct 2 '11 at 14:34
  • WHY LTS? they are normally not as up-to-date as the "normal" releases are. – Alvar Oct 2 '11 at 15:48
  • @Alvar: I can't really get into the reasons, but there are reasons. It's not just on a whim. – Daenyth Oct 3 '11 at 16:24

It looks like Xorg isn't able to load the kernel nvidia driver. You can try to load it manually:

sudo modprobe nvidia-current

If that fails with an error message indicating that the module couldn't be found, make sure you have the nvidia-current module listed in:

dkms status

Otherwise, include the lsmod output and/or output from that modprobe command in your question details.

  • I did try to modprobe nvidia before, which failed. I tried a depmod -a after that, didn't help. I'll try your suggestions today. – Daenyth Jul 29 '11 at 13:49
  • I updated the question to reply to your suggestions. It didn't work – Daenyth Jul 29 '11 at 16:27

If this is a hybrid graphics laptop with Nvidia Optimus, you may want to try bumblebee:

b) try bumblebee for simultaneously using the intel and nvidia cards:

sudo apt-get install git
# type password
git clone http://github.com/MrMEEE/bumblebee.git
cd bumblebee/
sudo ./install.sh
optirun glxgears
optirun glxspheres

Check the speed and compare to running it without optirun:

optirun glxgears
optirun glxspheres
# close window

For a WebGL benchmark, install google-chrome or use a WebGL-enabled browser and can try it with/without optirun and report the FPS values on the mailing list:

optirun google-chrome http://webglsamples.googlecode.com/hg/aquarium/aquarium.html
# close window
google-chrome http://webglsamples.googlecode.com/hg/aquarium/aquarium.html
  • The system does not have more than one graphics card in it. Is this an official ubuntu project? I don't think I can use something that's not directly supported for this. Also as I said in the post, the nvidia driver worked for this hardware in Karmic with no setup or configuration needed, so there should be some kind of solution in lucid. Does bumblebee support hardware accelerated graphics? – Daenyth Jul 29 '11 at 19:21

AFAIK nVidia ION is a hybric graphics card using Optimus (on laptops). Optimus is not supported by the nvidia drivers nor the nouveau driver.

Anyway, if you want to use the nvidia driver, make sure that the nouveau driver is unloaded:

sudo rmmod nouveau

To avoid it from being loaded the next boot, blacklist it:

echo blacklist nouveau | sudo tee /etc/modprobe.d/blacklist-nouveau.conf

If this does not help, check your /var/log/kern.log file for any helpful messages.

Ubuntu does a great job on autoconfiguring the X server, it's generally not necessary to use an own xorg.conf file. Try removing or renaming that file to let Ubuntu autoconfigure X.

nvidia-current builds a kernel module using dkms. For that, kernel headers matching your running kernel must be installed. The latest linux-generic package is version 2.6.32-33 ( The latest kernel headers are provided by the linux-headers-generic package. If you do not want to upgrade your kernel, install at least the kernel headers of the current kernel:

sudo apt-get install linux-headers-$(uname -r)

After that, the nvidia-current module should be built automatically. If not, run sudo dpkg-reconfigure nvidia-current.

  • That's strange. This device worked fine with nvidia as the driver with Karmic installed. I'll update my question a bit. I've already added a blacklist to modprobe, I'll post that. – Daenyth Jul 28 '11 at 17:44
  • Do you really need a custom xorg.conf file? – Lekensteyn Jul 28 '11 at 19:36
  • Without one, it uses vesa, which isn't something we can use for this system. – Daenyth Jul 28 '11 at 20:04
  • Edit /etc/modprobe.d/blacklist-framebuffer.conf and remove the hash sign (#) before blacklist vesafb. You might need to run sudo update-initramfs -u afterwards. – Lekensteyn Jul 28 '11 at 20:53
  • ION is only a moniker for the graphics chip that nvidia make for netbooks but it is not the same as Optimus. Also on my 10.04, nouveau should already be blacklisted in /etc/modprobe.d/nvidia-graphics-drivers.conf. – daithib8 Jul 29 '11 at 10:24

I was unable to get the nvidia driver working, but the nouveau driver seems to perform acceptably.

  • This should be edited in the question. It's NOT an answer. – Alvar Sep 30 '11 at 19:55
  • 1
    @Alvar: It's the path I ended up going with since it's been several months with no progress on it. – Daenyth Sep 30 '11 at 19:58
  • 1
    still if someone else with the same problem would go in here and try to do what you did, how would they do it then? We don't only ask stuff to get our own answer we do it so the community gets better and more answers for problems regarding ubuntu. – Alvar Sep 30 '11 at 20:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.