4

I have two hosts in my network. Both are connected to my router. From another host, I can ping and ssh into both of them. Both have an excellent connection to all other hosts. However, they cannot ping or see one another. One (192.168.124.101, called Hallway) runs Ubuntu 14.10, the other (192.168.124.104, called Rapunzel) is a Raspberry Pi with Raspbian. Both addresses are static. The hosts are connected to the electrical network through Powerline adapters.

Some output:

jos@hallway:~$ ifconfig eth1
eth1      Link encap:Ethernet  HWaddr 00:14:85:82:2a:2f
          inet addr:192.168.124.101  Bcast:192.168.124.255  Mask:255.255.255.0
          inet6 addr: fe80::214:85ff:fe82:2a2f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2959658 errors:0 dropped:91 overruns:0 frame:0
          TX packets:2366877 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3406445368 (3.4 GB)  TX bytes:964531766 (964.5 MB)
          Interrupt:21
jos@hallway:~$ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         Comtrend.Home   0.0.0.0         UG    0      0        0 eth1
192.168.124.0   *               255.255.255.0   U     0      0        0 eth1
jos@hallway:~$ arp -a 192.168.124.104
rapunzel (192.168.124.104) at b8:27:eb:a4:84:a3 [ether] PERM on eth1    

and vice versa:

pi@Rapunzel ~ $ ifconfig eth0
eth0      Link encap:Ethernet  HWaddr b8:27:eb:a4:84:a3
          inet addr:192.168.124.104  Bcast:192.168.124.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:60981 errors:0 dropped:0 overruns:0 frame:0
          TX packets:40710 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:19883333 (18.9 MiB)  TX bytes:2562029 (2.4 MiB)
pi@Rapunzel ~ $ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         Comtrend.Home   0.0.0.0         UG    0      0        0 eth0
192.168.124.0   *               255.255.255.0   U     0      0        0 eth0
pi@Rapunzel ~ $ arp -a 192.168.124.101
hallway (192.168.124.101) at 00:14:85:82:2a:2f [ether] on eth0

I have tried adding and deleting routes and arp entries. The current arp entries were added automatically, however (so there is some sort of contact). At first, a ping on either side would mention that the other side was "Destination host unreachable". The arp entries would give "<incomplete>" as the MAC address. After the arp entries were added, the pings simply time out.

It is probably not a firewall problem, for I have never used iptables on either of these machines (sudo iptables -L gives the default output on both hosts). I have rebooted both machines and the router, but so far nothing helps.
Things worked until yesterday, when I disconnected and reconnected one of the hosts. What am I overlooking?



Edit: I ran a tcpdump arp from host 101, and sure enough, I got numerous requests like the following:

23:12:23.460191 ARP, Request who-has hallway tell rapunzel, length 46
23:12:23.460214 ARP, Reply hallway is-at 00:14:85:82:2a:2f (oui Unknown), length 28

So why does no other traffic get through?

I ran an arping probe from both sides:

jos@hallway:~arping -b -D -w 2000 -I eth1 -s 192.168.124.101 192.168.124.104
ARPING 192.168.124.104 from 192.168.124.101 eth1
^CSent 38 probes (38 broadcast(s))
Received 0 response(s)

and something similar at the other end (only formatted differently, this is Raspbian after all).

  • Let's try more troubleshooting. Can you run tcpdump -nn -i eth1 icmp on hallway and tcpdump -nn -i eth0 icmp on rapunzel, then run ping 192.168.124.104 from hallway. What's the output from both tcpdumps and the actual command? Then let's do the same thing for ssh. Run tcpdump -nn -i eth1 port 22 on hallway and tcpdump -nn -i eth0 port 22 on rapunzel, then run ssh username@192.168.124.104 from hallway. What's the output from both tcpdumps and the actual command? – Alaa Ali Nov 19 '14 at 2:05
4
+50

Probably a dumb question: Are these both directly connected into the router or are they going through a switch? If through a switch, turn off both hosts, turn off switch, turn off router. Turn on router, turn on switch, turn on hosts.

(If you can give me more info on the exact brand of the switch, I might be able to tell you how to reset just the 3 ports of the switch)

Leaving the above in as not everyone is using powerline adapters, but un-plug/replug the powerline adapters and/or update their firmware to "unstick" them… >:)

  • The ethernet cards of both hosts are connected to the electric network through Powerline adapters. I edited the question to add this info. Thank you for commenting, but I don't think this answers the question. – Jos Nov 17 '14 at 7:30
  • Do you use MAC address spoofing on any of the hosts in your network? If not, maybe on the router??? ("clone MAC address") – Fabby Nov 17 '14 at 10:52
  • If yes, turn off. If not, try on halway: arping -b -D -w 2000 -I eth1 -s 192.168.124.101 192.168.124.104 On Rapunzel, try: arping -b -D -w 2000 -I eth0 -s 192.168.124.104 192.168.124.101 and report back with the output of both! – Fabby Nov 17 '14 at 11:16
  • Thanks Fabby. No MAC address spoofing going on here, "clone MAC address" is off on the router. I ran an arping from both sides and added the output above. – Jos Nov 17 '14 at 15:20
  • Now I'm stumped too! :( Another dumb question: did you: shutdown both hosts, unplug and replug both powerline adapters and then turn on both hosts??? These powerline adapters are normally not professional-level switches, so they could be "stuck" somewhere... Another thing, could you provide output on ifconfig for halway and not just ifconfig eth1 (I'm now less stumped and suspecting 2 internal NICs and halway responding on eth0) – Fabby Nov 18 '14 at 4:45
2

This turned out to be not as interesting as it first appeared. As Fabby mentioned, the powerline adapter must have got stuck. I connected one of the hosts to a different adapter and it worked straight away. Then I reconnected it to the first adapter, and again no traffic got through. While it would appear that the adapter has a hardware failure, keep in mind that it is only blocking traffic to and from one particular host. Thank you Fabby and Alaa Ali for your suggestions.

  • Hah! So IMHO you should accept my answer as the right one after I move my comment to replug the powerline adapter... :P (I'll also be happy if you upvote my answer... At least I'll get some credit out of all the work I've put into this...) En... Graag gedaan, Jos! >:) – Fabby Nov 23 '14 at 11:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.