I am using Ubuntu 11.04 64-bit as my only OS on my desktop computer, which used to only run Ubuntu 10.04 LTS until I had the time to upgrade it with a fresh install. It uses integrated NVIDIA graphics (listed as a GeForce 6150SE nForce 430 by the NVIDIA X Server Settings utility) with the current proprietary driver as provided by the Additional Drivers utility, and has a VGA connection to a 1680x1050 Acer monitor.

I used to get the (ugly-looking version of) Plymouth graphical boot screen while under 10.04. It didn't look that great, but I was fine with it. Now, it doesn't show on 11.04 at all during boot (I just get an error message in a moving gray box from the monitor saying "Input Not Supported"), and only rarely it will show on shutdown, all garbled up. I could not get GRUB to show during boot while holding down Shift, either (same error message), but pressing Enter while it should be up starts the system normally.

A picture of the error message I was getting: A picture of the issue (please excuse the poor quality, a Nintendo DSi camera was all I had on hand)

Once fully booted, the system still shows the login screen and desktop just fine.

Any information on how to troubleshoot this would be appreciated. If there's any hardware-specific stuff I forgot to include here, let me know the relevant commands to run in a comment below.

Things that I've tried:

  1. Running plymouth in a framebuffer: no effect
  2. Booting with nomodeset as my grub boot: option no effect
  3. Booting with nomodeset and plymouth in a framebuffer: no effect other than Plymouth showing during shutdown only
  4. Following the Softpedia instructions for fixing Plymouth's resolution: Problem mostly solved, except logo does not show in Plymouth during boot, and both grub and Plymouth are slightly off-center
  5. 4 above, but with nomodeset removed as a grub boot option: same effect as #4

  6. 5 above, but with vt.handoff=7 added as a grub boot option: same effect as #4

I have added the current contents of /etc/default/grub as requested in the comments:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=uvesafb:mode_option=1280x1024-24,mtrr=3,scroll=ywrap"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)

# Uncomment to disable graphical terminal (grub-pc only)

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux

# Uncomment to disable generation of recovery mode menu entries

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

CURRENT STATUS: I forgot to uncomment one line as per "things that I've tried" #4, so I took care of that. I can now see GRUB during startup when I hold Shift and a normal-looking Plymouth during shutdown...but Plymouth during boot is now just a solid purple screen. In each case, it's displayed a little off-center to the left, with a thin black bar running down the right side of the monitor. The error pictured above no longer shows. I'd say this problem is about 2/3 solved now.

UPDATE: After Natty started freezing up on me, I decided to dual-boot with Oneiric, which unfortunately shows the same problems. Rather than trying all these workarounds though, I decided to do what I should have done from the start and file a pair of bug reports.

LAST UPDATE: Bug 850908 has been confirmed as a legitimate nouveaufb bug. I have overwritten my 11.04 partition with 12.04 LTS, and I can confirm at this time that the issue is present there, as well. I will now flag this question to be closed, yet I hope it was helpful for anyone who experienced similar issues; if you are still having the same problem as me, please go there and mark yourself as affected. Thanks!

  • ok (its worth deleting your comments to tidy up the thread like I have done!) - GRUB_GFXMODE is still commented out - it should be GRUB_GFXMODE=1280x1024. You have the full set of options in GRUB_CMDLINE_LINUX_DEFAULT. I presume you have done step 3 successfully? If this doesnt work, remove the line in step 3, recomment out (add the #) to GRUB_GFXMODE and change GRUB_CMDLINE_LINUX_DEFAULT back to "quiet splash" - dont forget to do step 5 and 6 again. – fossfreedom Aug 1 '11 at 20:56
  • @fossfreedom I've cleaned things up a little and updated my question. I took care of that one line and while things still aren't perfect yet, most of the startup issues have been resolved. Thanks for catching that! – Christopher Kyle Horton Aug 2 '11 at 2:48
  • @fossfreedom Just tried your last suggestion, and it didn't seem to have any effect, so I'll just leave it that way for now. I'd say grub and Plymouth now show for the most part though, which was my original question anyway; you can post how you've been helping me up to now as an answer and I'll accept it unless someone else posts something which also clears up the other minor issues. – Christopher Kyle Horton Aug 2 '11 at 19:16
  • Warrioring64 - one more try - try adding vt.handoff=7 to your grub boot option - either by itself or in combination with your current boot options. – fossfreedom Aug 4 '11 at 18:02
  • I'm actually starting to wonder whether my problems qualify in any way as a bug that should be filed? – Christopher Kyle Horton Aug 5 '11 at 21:12

If grub is not displaying correctly, you can try modifying these settings in /etc/default/grub:

# Uncomment to disable graphical terminal (grub-pc only)

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'

By default, grub will try to use the "preferred" video resolution as returned by the video card via VBE. If the mode specified here is not compatible with your monitor, you can try commenting out gfxmode entirely and running sudo update-grub to let it use the video card's default mode; you can set GRUB_GFXMODE=640x480 to specify a mode that any VGA-connected monitor should support; or you can uncomment *GRUB_TERMINAL=console* to switch to a text-only mode that should display.

Once you're able to load grub, you can get a grub shell by hitting the 'c' key, and can then get information about available video modes with the 'vbeinfo' command; you could then try these one by one until you find the best mode that's compatible with your monitor. Note that even if your video card supports the 1680x1050 resolution of the monitor, it may not be supported when in BIOS mode; this is what the vbeinfo command tells you.

It's also possible that you may need to adjust the settings on the monitor so it will be ok with handling the input you're trying to send it.

Once you're able to find a mode that's satisfactory for grub, you should be able to apply the same mode to the uvesafb framebuffer via the kernel commandline to get the same results for plymouth.

| improve this answer | |

Did you try setting GRUB_CMDLINE_LINUX="gfxpayload=true"? Also set GRUB_GFXMODE and GRUB_GFXPAYLOAD_LINUX to both your system and grub supports.

Maybe some this helps you as well:

How do I get my blacked out ttys back?

| improve this answer | |
  • Just tried this, but I can't 1680x1050 resolution, only 1280x1050. Otherwise no effect from what I've tried above. Nice to know I'm not the only one with this issue, though. – Christopher Kyle Horton Aug 5 '11 at 21:06
  • Yes, to get gfxpayload to work you must add a line in /etc/grub.d/00-header described here: harrison3001.blogspot.com/2009/09/… It's a small canche but giving it a try won't hurt. Helped me a bit. I filed a bug report on this type of plymouth problems a while ago. Nothing till today... – con-f-use Aug 6 '11 at 8:27

As you are using the Nvidia proprietary driver, may I ask have you looked at the Nivida X Server Settings configuration for that external monitor? May be some adjustment there might make a difference. The Input Not Supported message is coming from the monitor. The signal is coming from the Graphic adapter. So, the issue could be down to incorrect settings in the Nvidia X Server.

| improve this answer | |
  • Would you have any suggestions for specific settings I should check? Nothing there looks out of the ordinary to me whenever resolution comes up. – Christopher Kyle Horton Aug 5 '11 at 21:09

I have the same issue with my desktop (AMD x4 desktop running 11.04 and NVIDIA drivers) so the problem is with Plymouth not detecting your monitor type.

Plymouth is an application that runs very early in the boot process (even before the root filesystem is mounted!) that provides a graphical boot animation while the boot process happens in the background.

There is a product called Plymouth Manager, and you can add it by going to the terminal and entering ...

sudo add-apt-repository ppa:mefrio-g/plymouthmanager
sudo apt-get update
sudo apt-get install plymouth-manager

In that program it allows you to change the resolution at boot up and select the standard theme or a custom theme of your liking.

Hope that helps.

| improve this answer | |

you can try installing startup manager. i think the bootloader menu in your case is showing in a resolution of 640x480. i had a similar problem (i think) in which my monitor just shows 'out of range' and pressing enter does the trick (since i'm on dual boot too). there's an option in startup manager to change the resolution, max i think is 1280x1024 or 1900x1200.

| improve this answer | |
  • 1
    I highly discourage you from using startup manager. It is not in sync with Ubuntus way of doing things and might break your system. – con-f-use Aug 5 '11 at 12:14
  • 1
    thanks for the heads up, got to be extra careful from now on for sure. :) – Makoy M Aug 5 '11 at 12:40
  • I use Startup Manager on my parents' Windows XP/Ubuntu 10.04 dual-boot desktop to let them pick Windows as default, so I'm familiar with it. I would rather not use it in my situation though, as I actually use Ubuntu 11.04 as my only OS on my desktop. I'll clarify this in the question. – Christopher Kyle Horton Aug 5 '11 at 16:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.