3

After unsuccessful installation of the latest version of MariaDB through repository that is offered by official page (for Ubuntu 14.04) I've tried to install mariadb-5.5 which is already included in Ubuntu 14.10. However I get the following error:

Setting up mariadb-client (5.5.39-2) ...
dpkg: dependency problems prevent configuration of mariadb-server:
 mariadb-server depends on mariadb-server-5.5 (>= 5.5.39-2); however:
  Package mariadb-server-5.5 is not configured yet.

dpkg: error processing package mariadb-server (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                    Processing triggers for libc-bin (2.19-10ubuntu2) ...
Processing triggers for ureadahead (0.100.0-16) ...
Errors were encountered while processing:
 mariadb-server-5.5
 mariadb-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

But whatever I do nothing works. I've tried to solve my problems by:

Nothing of listed above helps me. Please, I need a help!

4

I solve it! Before the appearance of problem I've update the Ubuntu base. So the solution is dead simple: reboot the system! :)

  • 2
    Incredible! It actually solved my problem as well O_O – Eek Nov 24 '14 at 10:06
1

It seems that the mysql-server was installed but not configured. This can happen when apt ist interrupted, for example by Ctrl-C.

You can finish configuration of installed packages by issuing sudo dpkg --configure -a and then install all the missing packages by issuing sudo apt-get -f install.

If you are running into problems doing that, I'd suggest using dpkg to remove mysql-server first by issuing sudo dpkg --remove --purge mariadb-server

Doing this, you might face other packages blocking installation, you should be able to deal with them similarly.

  • Sorry, but it doesn't solve the problem. I still get the same error – Timur Fayzrakhmanov Nov 12 '14 at 16:02
1

Nothing above helped me but specifying version for mysql (dependencies) packets helped. I installed mariadb 10.1.

apt-get install mariadb-server mysql-common=10.1.19+maria-1~trusty libmysqlclient18=10.1.19+maria-1~trusty

You can get versions with

apt-cache policy mysql-common

You can always rollback with

apt-get remove --purge mysql* mariadb*

If you don't have any data or special config do also

rm -R /etc/mysql
rm -R /varl/lib/mysql

If you use MariaDB hosted repo you could PIN a package to avoid future upgrade problems.

/etc/apt/preferences.d/00mariadb.pref
Package: *
Pin: release o=MariaDB
Pin-Priority: 1001

Also note that I tried all other instruction with server reboot, package purging and reinstalling and force installing. It seems to me it is all connected with the fact that going from mysql or percona to mariadb something does not purge/uninstall completely.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.