I have a acer aspire 5820T with a broadcom 43225 wireless card. I previously used ubuntu 10.10 and the wireless worked straight away, but when I updated to 11.04 the wireless stopped working.

I have managed to get the wireless hardware to switch on for a couple of seconds before turning off (When you turn the wireless on using the manual switch the wireless light stays on for a couple of seconds and in the drop down connections menu the information under wireless networks changes from 'device not ready' to 'Disconnected' but shows no wireless networks despite there being one).

So far I have tried installing an additional driver, and also disabling the additional driver and installing b43-fwcutter and firmware b43 installer. There may have been other things that I've found in searches that i've tried but unfortunately I can't remember them.

Any help would be appreciated.

2 Answers 2



Its not an ungenerous statement that you are not alone with Broadcom issues.

Ubuntu does try its best by offering you what it thinks is the best driver.

I would advise you should stick with the STA driver offered to you for Natty (11.04) for this wireless card.

acer & kernel diagnosis

For the Natty (11.04) kernel there is a particular issue with Broadcom kernel driver clashing with the acer-wmi kernel module.

To test if you are suffering with this issue, run the following:

rfkill list all


If the output from rfkill list all says it is "acer-wireless: soft blocked: yes" then run the following:

sudo modprobe -r acer-wmi
cd /etc/modprobe.d
sudo vi blacklist.conf

Then add blacklist acer-wmi as a new line at the end of the file.

What this does is hide from the kernel the visibility of the acer-wmi kernel module. Don't worry too much, this module has now power implications.

When you reboot - your wireless will be correctly recognised.



I've found that pm-powersave switches wireless OFF when switching to battery. See Why is wireless down/strange after switching to battery or closing/opening the lid?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .