1

Cannot use twofinger on lenovo z5070 touchpad ubuntu 14.04.

I also tried

twofinger scroll on lenovo g50

ALPS touchpad detected as PS/2, corrected with psmouse-dkms-alpsv7 but reset after reboot

Ubuntu 14.04 - Lenovo Ultrabook Touchpad Drag not working

pointing devices

when I use command synclent

It return "Couldn't find synaptics properties. No synaptics driver loaded? "

I also tried to reinstall xserver-xorg-input-synaptics

sudo apt-get purge xserver-xorg-input-synaptics sudo apt-get install xserver-xorg-input-synaptics

2

My solution.

cat /proc/bus/input/devices

if you found something like this

N: Name="ETPS/2 Elantech Touchpad" then do the next procedure

apt-get install dkms

if cannot access dkms. try

export PATH=$PATH:/usr/local/sbin

Step 1: Download the following dkms package

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1166442/+attachment/3941591/+files/psmouse-elantech-x551c.tar.gz

Step 2: Run the following commands in the download directory (or adjust the paths accordingly):

sudo dkms ldtarball psmouse-elantech-x551c.tar.gz

sudo dkms install -m psmouse -v elantech-x551c

sudo rmmod psmouse

sudo modprobe psmouse

ref.

https://superuser.com/questions/721417/elantech-touchpad-recognized-as-ps-2-mouse-ubuntu-13-10

http://www.evilcodingmonkey.com/2014/01/23/ubuntu-activate-multi-touch-on-elantech/

https://bbs.archlinux.org/viewtopic.php?id=157091

https://superuser.com/questions/595818/add-usr-local-sbin-to-the-path-of-a-user

http://www.evilcodingmonkey.com/2014/01/23/ubuntu-activate-multi-touch-on-elantech/

| improve this answer | |
  • Works but my right click is not working now what about you ? – Saurabh7 Mar 26 '16 at 6:48
  • as same as you T^T – UmAnusorn Apr 4 '16 at 4:15
  • Upgrade the kernel version, worked for me and remove this. – Saurabh7 Apr 4 '16 at 4:49
  • Ty, I will try to upgrade the kernel. – UmAnusorn Apr 4 '16 at 6:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.