0

I have a trouble with my Ubuntu 14.10. I want to install additional driver for my AMD graphic card but when I choose fglrx-updates in "Software & Updates" -> "Additional Drivers" and press "Apply Changes" nothing is done. I use Main server for installing software, and the checkbox "Proprietary drivers for devices (restricted)" is enabled.

I thought about installing the "fglrx-installer-updates" package or downloading from the official site, but I remember with manual installed drivers on Fedora and want to avoid similar troubles.

Thanks in advance.

P.S. My graphic card was detected as "Advanced Micro Devices, Inc. [AMD/ATI]: Seymour [Radeon HD 6400M/7400M Series]".

0

I recommend you install the default option of fglrx on ubuntu repositories instead fglrx-updates. Follow the instructions below to solve this issue.

On the console (Ctrl+Alt+F1)

Uninstall and remove all configuration files:

sudo apt-get purge fglrx*

Install the proprietary package on Ubuntu repositories:

sudo apt-get update && sudo apt-get install fglrx fglrx-amdcccle

Create a new xorg.conf

sudo aticonfig --initial

Restart the PC

sudo reboot
  • When I've tried to type sudo apt-get install fglrx fglrx-amdcccle I got the message The following packages have unmet dependencies: fgrlx: fglrx-core but it is not going to be installed. E: Unable to correct problems, you have held broken packages. When I've tried to type sudo apt-get install fglrx fglrx-core fglrx-amdcccle the packages ocl-icd-libopencl1 ocl-icd-libopencl1:i386 wine wine1.6 wine1.6-amd64 wine1.6-i386:i386 were able for removing. – Ósanwe Nov 13 '14 at 9:56
  • did you performed sudo apt-get purge fglrx* before? perform sudo apt-get autoremove; sudo apt-get update && sudo apt-get install -f fglrx fglrx-amdcccle – Marcos Silveira Nov 13 '14 at 14:33
  • The problem was because of wine. This package had broken a whole installation process. I just removed it and could install fglrx. – Ósanwe Nov 13 '14 at 16:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.