0

I'm running 12.04 on an i5 laptop with intel graphics and I noticed last week that webgl no longer worked on chrome. It has in the recent past and I can't think of anything I would have done to break it. I though it was chrome and followed several pieces of advice about setting chrome's flags and gpu blacklists but nothing worked. I have firefox installed but hardly use it so I decided to see if webgl will work with firefox but it doesn't.

So, I think its my gpu, I tried updating the drivers and rebooting but still no webgl.

lspci -v outputs:

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09) (prog-if 00 [VGA controller])
Subsystem: Lenovo Device 3977
Flags: bus master, fast devsel, latency 0, IRQ 42
Memory at e0000000 (64-bit, non-prefetchable) [size=4M]
Memory at d0000000 (64-bit, prefetchable) [size=256M]
I/O ports at 3000 [size=64]
Expansion ROM at <unassigned> [disabled]
Capabilities: <access denied>
Kernel driver in use: i915
Kernel modules: i915

Looking at chrome://gpu I see:

Graphics Feature Status
Canvas: Software only, hardware acceleration unavailable
Flash: Software only, hardware acceleration unavailable
Flash Stage3D: Software only, hardware acceleration unavailable
Flash Stage3D Baseline profile: Software only, hardware acceleration unavailable
Compositing: Software only, hardware acceleration unavailable
Rasterization: Software only, hardware acceleration unavailable
Threaded Rasterization: Unavailable
Video Decode: Software only, hardware acceleration unavailable
Video Encode: Software only, hardware acceleration unavailable
WebGL: Unavailable

And:

Problems Detected
GPU process was unable to boot: GPU process launch failed.
Disabled Features: all
EXT_occlusion_query appears to be buggy with Intel GPUs on Linux
Applied Workarounds: disable_ext_occlusion_query
Clear uniforms before first program use on all platforms: 124764, 349137
Applied Workarounds: clear_uniforms_before_first_program_use
Mesa drivers in Linux handle varyings without static use incorrectly: 333885
Applied Workarounds: count_all_in_varyings_packing
Multisampling is buggy in Intel IvyBridge: 116370
Applied Workarounds: disable_multisampling
Disable partial swaps on linux drivers: 339493
Applied Workarounds: disable_post_sub_buffers_for_onscreen_surfaces
0

I believe that this graphics card is not supported for WebGL, as per the link below.

https://www.khronos.org/webgl/wiki/BlacklistsAndWhitelists

Chrome on Linux

  • WebGL is enabled on ATI/AMD GPUs with proprietary AMD drivers 8.98 or newer.
  • WebGL is enabled on certain Intel GPUs with recent Mesa drivers.
    • Multisampling is disabled on Intel IvyBridge cards.
  • WebGL is enabled on NVIDIA GPUs with proprietary NVIDIA drivers newer than 295.
    • WebGL is always disabled on NVIDIA Quadro FX 1500.
    • WebGL is disabled on the dynamically switching NVIDIA+Intel GPUs.

I would be interested in knowing what was different in your environment before when it was working. Perhaps support has been dropped for older intel gpu's, but I was not able to find evidence of that in the linked page's history.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.