0

I recently installed Ubuntu 14.04 on my Asus laptop and all went well until i tried to use the wifi and it says "Wi-Fi is disabled by hardware switch" and thats not good. I looke around here and only thing that worked was this: Wifi is disabled by Hardware Switch - Compaq 610 It worked but like he said it works until reboot then i have to enter it again. rfkill list all shows

`0: phy0: Wireless LAN Soft blocked: no Hard blocked: yes 1: asus-wlan: Wireless LAN Soft blocked: no Hard blocked: no

EDIT: I have seen, and it has worked for the most part. I still cant turn on/off from keyboard but i no longer have to suspend for it to be functional. chili you are AWESOME and i thank you very much . `

4
  • Do you have a dual boot system with Windows OS? Do you have physical shortcut key to tuning ON/OFF for your wifi on your keyboard? Nov 12 '14 at 6:29
  • Well, i think i technically have windows on the hdd but not i dual boot... And i have the fn+f2 to turn on/off the wifi but it has done nothing.
    – Corbin
    Nov 13 '14 at 6:04
  • Is It On virtualbox installed? Does that work on windows? turn on the wifi by fn+f2 in windows and run rfkill list all and check if you see any changes. And if @chili555's answer works for you, so you want that on suspend and wakeup mode too? Nov 13 '14 at 6:10
  • Its not on virtualbox, it worked on windows, and chili555's i found and he simply told me how to make a majority of it automated. But the commands require me to suspend the laptop to make them work, i am wondering if there is a way to get around that also.
    – Corbin
    Nov 13 '14 at 6:49
1

Let's get the sequence of commands to run automatically on boot. Please open a terminal and do:

gksudo gedit /etc/rc.local

Use nano or kate or leafpad if you don't have the text editor gedit. Right above the line exit 0, add these three lines:

rmmod -f ath9k
rfkill unblock all
modprobe ath9k

Proofread carefully, save and close the text editor. Reboot.

Is it working as expected?

If this is ineffective or only partially effective, let's try a different technique. Please edit /etc/rc.local as I outlined above and remove the lines you added. Proofread carefully, save and close the text editor.

Now do:

sudo -i
echo "options asus-nb-wmi wapf=1" > /etc/modprobe.d/asus.conf
exit

Then the Fn+F2 (or some such) key combination to enable and disable wireless should be working properly.

There are other possible values for wapf, so if =1 is ineffective, we will try the others.

6
  • Well this works just as it should, besides i still have to suspend and wake the laptop get it to work. Is there a way to also not have to do this?
    – Corbin
    Nov 13 '14 at 0:37
  • Please check: lsmod | grep asus. Is the module asus-nb-wmi loaded? I may have a much better solution.
    – chili555
    Nov 13 '14 at 13:48
  • it says the following:
    – Corbin
    Nov 14 '14 at 4:39
  • asus_nb_wmi 16990 0 '&' asus_wmi 24191 1 asus_nb_wmi
    – Corbin
    Nov 14 '14 at 4:41
  • I have no idea what it means but im sure its what you are looking for...
    – Corbin
    Nov 14 '14 at 4:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.