4

I have a high resolution screen on my laptop (3200x1800px) and I disabled the boot-image
( How do I disable the boot splash screen, and only show kernel and boot text instead? )

I also managed to enlarge the font in grub by uncommenting the line

GRUB_GFXMODE=640x480

in /etc/default/grub

But the boot messages during startup are still really tiny and hardly readeable. The same as if I change to a console screen by pressing Ctrl+Alt+F1.

How can I enlarge the font on the console too?

5
  • Out of curiosity, are you using EFI mode in your BIOS? – PJ Singh Nov 12 '14 at 3:54
  • I think i turned it off in BIOS – rubo77 Nov 12 '14 at 7:13
  • OK. One of the benefits of EFI is to allow grub to access your video card's capabilities early in the boot process, allowing for higher resolutions during boot. If you had not turned it off, I was going to suggest you do. If the "GRUB_GFXPAYLOAD_LINUX=keep" approach did not help, see if there is a Legacy Compatibility Mode (or some similar name); if you can enable that, it might make grub think you don't have EFI support in your video card. Depending on your BIOS, you might be able to disable EFI support specifically for your video card. – PJ Singh Nov 12 '14 at 15:33
  • don't think it has to do with it, In the beginning of the boot process the first 100 lines are still in a good geadeable font, but then later it switches to 3200x1900 and then you cannot read anything any more. I would like to change that second step to a larger font – rubo77 Nov 12 '14 at 17:10
  • Related: askubuntu.com/questions/63824/… – rubo77 Nov 25 '14 at 19:58
4

You can configure the font on tty console with

sudo dpkg-reconfigure console-setup

leave all settings as they are but the last one, where you can chose the size.

(You have to reboot to get the new font on your console.)


Update:

This doesn't seem to work anymore on 15.04, but you can install the custom Ubuntu fonts for your console:

sudo apt-get install fonts-ubuntu-font-family-console

And create a script /usr/local/bin/fontset with this command:

#!/bin/sh
setfont /usr/share/consolefonts/Uni3-TerminusBold32x16.psf.gz

(choose the desired font out of the folder /usr/share/consolefonts/)

You can either call fontset each time on your console after using Ctrl+Alt+F1

or add these lines to your ~/.profile:

#load larger font on tty
if [ "$TERM" == "linux" ]; then 
 #sleep 1 # add this if you have problems
 /usr/local/bin/fontset
fi

This starts your script only if you are on a tty console.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.