6

I drag-dropped some links from the Chrome Browser onto the Desktop. But now when I try to move them they create a file rather than being moved.

1 enter image description here

2 enter image description here

3 enter image description here

Could someone tell me how to fix this. (And maybe why it is happening)

3 Answers 3

7

It's a bug (bugzilla.gnome.org, bugs.launchpad.net. As far as I know there is no way to fix this (without fixing it in the Nautilus source code).

7
  • I am running 14.10. Would reverting back to 14.04 fix this? Nov 11, 2014 at 19:40
  • No, Nautilus in 14.04 has the same bug. As far as I remember it's working in 12.04. Nov 11, 2014 at 19:47
  • So.. EVERYONE has this bug right now? Nov 11, 2014 at 19:58
  • Yes, everybody who is using Nautilus 3.10. I don't know if it's fixed in more recent versions of Nautilus. Nov 11, 2014 at 20:09
  • Thank you.. I am using version 3.10.1. So would you suggest that I switch to a different file manager? Nov 11, 2014 at 20:37
5

The current 16.01 LTS ships with gnome 3.14.4, and this bug is fixed in 3.15.4 onwards.

Backup and proceed with caution with the following...

You can update your version of nautilus, as shown in this SO answer:

sudo add-apt-repository ppa:gnome3-team/gnome3

sudo apt-get update && sudo apt-get upgrade

After a reboot, this worked for me, but I ended up with huge icons. The previous preferences icon zoom menu option disappeared, but then I found this SO answer, which worked for me:

  • open a file browser
  • click the icon view button
  • move the slider to the left

enter image description here

Note: Screen-shot credit to @Manje Brinkhuis

3

A handy workaround I discovered:

R click and choose cut on the link icon you want to move. Then R click and choose paste on the desktop location to which you want to move it. When a popup comes up and says "Do you want to replace?", say yes!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .