6

I am running (or at least trying to run) Ubuntu desktop 14.04.2 LTS on a Dell Optiplex 760 with intel Core2 Quad Q8300 CPU and an intel 4 series integrated graphics controller (uname -a :Linux systemname 3.13.0-53-generic #87-Ubuntu SMP Thu May 7 14:32:24 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux). Although I was able to load the desktop before, it fails to load now. What happens is that the purple screen with white ubuntu logo and the red over white dots below keeps on "loading" without changing, even after one hour of waiting time. I ran apt-get update and apt-get dist-upgrade which both do not result in any issues. I triend some of the suggestions listed here, but did not get any results:

  • When I try to run ccsm I get Gtkwarning: could not open display.
  • dconf reset -f /org/compiz does not run with exit code 1 and an "error spawning command line"
  • unity --replace has the following fatal error: compiz (core) - Fatal: Couldn't open display :0
  • reinstalling ubuntu-desktop works flawlessly as does unity and lightdm
  • mv ~/.config/dconf/user ~/.config/dconf/user.old does not help either

If more information is required I would gladly supply it. I can login and operate (as sudo) without any issues in tty1.

Update I am able to run startx and switch to tty8 where I can load the unity desktop environment. Everything works except the header (menu) bar (i.e. no username, time, hplip icon, dropbox icon, network icon, ...) the launcher also does not auto-hide. tty7 keeps still doing the same thing as described above (purple loading screen). In tty8 I get a system program crash notification from signon-ui.

Update 2

I also tried using a boot from a live USB with Ubuntu 14.04, as suggested in the comments below. This works flawlessly, and I immediately get the menu bar with time and everything in tty7.

Update 3 Trying to upgrade to 14.10 does not work either it appears the changes cannot be calculated. A bug report was submitted.

Update 4 The upgrade to 14.10 succeeded after the bug report was marked as a duplicate. Uninstalling gnuplot allowed for 14.10 to be isntalled. The behaviour was even worse as the launcher nor menu bar were available in the startx desktop environment. However a subsequent upgrade to 15.04 resolved all the issues. Nonetheless, I accept the answer below. I did not verify if it works since I fixed my problem another way but the author claims this is the easiest answer to my original problem as stated here.

  • 1
    I am able to run startx and switch to tty8 where I can load the unity desktop environment. Everything works except the header bar (i.e. no username, time, hplip icon, dropbox icon, network icon, ...). tty7 keeps still doing the same thing as described above (purple loading screen). In tty8 I get a system program crash notification from signon-ui. This is very puzzling behaviour and I cannot figure out what causes it. – FM Kerckhof Nov 11 '14 at 18:18
  • 1
    This is indeed puzzling behaviour. Was this a clean install or an upgrade to 14.04? what's the output of uname -a? Do you have similar issues if you boot from a live media? – Elder Geek Nov 12 '14 at 3:05
  • 1
    did you check the hash (md5sum) of your .iso file to insure that your image is accurate? Also "no success" tells me near to nothing. Please edit your question and add what you've tried, what the results were, any and all error messages you receive. Thank you for helping us help you. Comments are for clarification and getting a specific users attention, but information regarding your problem should always be added to your question by editing. – Elder Geek Feb 16 '15 at 13:35
  • 1
    @FMKerckhof, try boot and press F8. It's the same as dmesg but you may notice the sequence and when it stops. Another thing you may try that worked for me for an old machine, at boot press shift to boot in recovery mode then select to continue boot as normal. – user.dz May 11 '15 at 19:22
  • 1
    @Sneetsher normal booting in recovery mode gives exactly the same issues as before. I have also tried booting in recovery mode with failsafe graphics mode here I get the option to "run for one session in low graphics mode" which I select and then I get the message "stand by one minute while the display restarts" which lasts for more than 15 minutes. Removing anacron from startup does not help either, then the F8 output just stops after starting the CUPS pringting spooler/server – FM Kerckhof May 12 '15 at 14:04
3
+50

Try this if this helps but make a copy first of this file beginning with ".ICE*" and paste the copy into gedit editor and save this as different name-file ...

then do this in terminal :

rm .ICE*

and reboot your machine off-line.

  • 1
    yes, it is easy to change to a different Desktop wm or to reinstall this wm simply and this answer of me is the shortest way to solve this problem as described in question above. So this ICE file will then be deleted and at next boot it will be fresh new there. – dschinn1001 May 15 '15 at 4:53
  • Hi thank you for the suggestion. However, as stated in the comments above the issues seems to have been resolved by upgrading over 14.10 (which was initially hampered by gnuplot for some reason, but I only saw after my bug report on launchpad was marked as a duplicate) to 15.04. Thank you very much. Just for clarity though: what would removing the .ICEauthority have accomplished? – FM Kerckhof May 15 '15 at 13:28
  • 1
    @FMKerckhof + here you find anything about ICEauthority and the inflicting fricklings when you dont remove ICE* simply with: rm .ICE* in your terminal as normal user (search words in google are : ubuntu removing the .ICE* file) + :o) + this could be too that there are login-attempts of "invisible" guests on your machine while you did not notice this and so you simply rm the responsible hidden files ... and shake off the persecutors then invisibly ... + you could check what you see in terminal before and after next re-boot with in terminal : w and in terminal to with : who – dschinn1001 May 15 '15 at 13:34
1

First login into tty by pressing CTRL+ALT+1

Note: Press ALT+7 to came out from tty

Solution 1: Reset the Unity and Compiz

  1. Download Unity Reset tool from here.

    Note: It should work with Ubuntu 14.04, 13.10 and 13.04.

  2. Reset Unity using the following command

    $ unity-reset
    

Solutiom 2: Reinstall Ubuntu Desktop (i.e Unity)

sudo apt-get install --reinstall ubuntu-desktop

Solution 3: Install other Desktop Environment like,Gnome, KDE..etc

Now, i suggest you try Gnome Desktop, it looks cool.

sudo apt-get install gnome-shell ubuntu-gnome-desktop

After trying any solution, just reboot your system.

$ sudo reboot
  • 1
    Thank you for your answer, but I already stated above that I tried solution 2 and re-installation went flawlessly but without resolving the issue. In the end I didn't need to install another desktop environment (as solution 3 suggest) since an upgrade to 15.04 just fixed my issues. I was not aware of the existence of the unity-reset tool, thanks for bringing it to my attention! – FM Kerckhof May 15 '15 at 13:38
  • ohh...i didn't read the above cmnt's . That's good, that you rectify this problem..... now next time you face this situation you can use any of these solution. FM Kerckhof – Akshay Pratap Singh May 15 '15 at 16:52
0

I had exactly the same issue.

I had followed the steps mentioned by @Akshay Pratap Singh, but when I try follow this step.

sudo apt-get install --reinstall ubuntu-desktop

I had dependency issues with libcheese and libgtk3

What i did was

sudo apt-get remove unity-control-center
sudo apt-get remove --force-yes libcheese
sudo apt-get remove --force-yes libgtk3
sudo apt-get install unity-control-center
sudo apt-get install ubuntu-desktop

And since my display driver is Intel i also installed the drivers for that

sudo apt-get install xserver-xorg-video-intel

And this had solved my problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.