3

Both my external and native keyboards have back and forward buttons (Thinkpad T400). I upgraded to Ubuntu 14.04 and the back and forward buttons on my external keyboard do not work. Can you help me fix this ?

xev gives 166 and 177 for the back and froward buttons on the native keyboard of my laptop but 113 and 114 for the external keyboard

If there was an automatic solution to use the right driver or mapping, I would prefer...

Thanks

0

What you're trying to do is to cram the keys of two keyboards into one keyboard.

How about turning the solution upside-down: try to make two keyboards work as two keyboards!

E.g. someone who has a French and a German keyboard, defines 2 keyboards: a French one and a German one and tells Ubuntu which one is being used.

So do the same: define two keyboards in System Settings - Text Entry, re-assign the keys as explained in this article and presto: you're up and running.

(If your layout is QWERTY US you take "English US" and "English US, alternative international", if you have QWERTZ, you take German and Swiss, French&Belgian, ...)

If you need more info, post a reply here.

|improve this answer|||||
  • Hi @Fabby... the article is crazy long !!! can you help me find a quick fix for ubunut 14.04 ? – Louis Feb 3 '15 at 10:55
  • Yes: the quickest fix is: don't do it! There! Done! – Fabby Feb 3 '15 at 11:48
  • ok you took it bad ! sorry, I didn't mean to. I am really not an expert in ubuntu, I am looking for a solution I can implement myself ! – Louis Feb 3 '15 at 11:49
  • No, I didn't take it bad... What you asked is a simple question with a complex answer, so it's going to take you a lot of work to accomplish what you want. The only quick fix for your problem is: Don't do it! (which doesn't mean my answer is not valid: it's still the most valid answer you've been given or are likely to get...) :P ;-) That little grey check-mark is asking to be turned green... – Fabby Feb 3 '15 at 12:14
0

I think it does not depend on Local keyboard settings. I have back button on external keyboard and it is displayed 166.

KeyPress event, serial 37, synthetic NO, window 0x3a00001,
    root 0x9e, subw 0x0, time 4815411, (-648,508), root:(540,560),
    state 0x0, keycode 166 (keysym 0x1008ff26, XF86Back), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

As you see on keyboard layout chart there are no special buttons like forward and back defined. So it is not out of the box setup. I have USB BTC keyboard so it could help if you shared with us what keyboard model do you use.

|improve this answer|||||
  • thanks, my keyboard is an external USB lenovo thinkpad keyboard : model # SK-8855 google – Louis Nov 22 '14 at 11:39
  • You know I found thread about your keyboard on page – miro5lav Nov 24 '14 at 18:58
  • that play with kernel drivers. My guess is you need USB HID Driver for kernel to make keyboard work. But try first available libs in Ubuntu PPA, e.g. type:sudo apt-get install libusbhid-common or other experimental lib libhidapi-libusb0 and see what happens. – miro5lav Nov 24 '14 at 19:18
  • @miro5slav Hi thanks for you advices, but the libraries did not change anything...any other ideas ? – Louis Feb 3 '15 at 10:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.