1

I encountered a SIGBUS error when starting up eclipse. There was nothing wrong before this, I've just turned on the laptop and the error appears:

$ eclipse
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGBUS (0x7) at pc=0x00007f08bd89063a, pid=4159, tid=139674439165696
#
# JRE version: OpenJDK Runtime Environment (7.0_65-b32) (build 1.7.0_65-b32)
# Java VM: OpenJDK 64-Bit Server VM (24.65-b04 mixed mode linux-amd64 compressed oops)
# Derivative: IcedTea 2.5.3
# Distribution: Ubuntu 14.04 LTS, package 7u71-2.5.3-0ubuntu0.14.04.1
# Problematic frame:
# C  [libzip.so+0x463a]
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /home/alvas/hs_err_pid4159.log
#
# If you would like to submit a bug report, please include
# instructions on how to reproduce the bug and visit:
#   http://icedtea.classpath.org/bugzilla
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

Has anyone had the same problem before? How do I resolved the problem?

Is it an IceTea JRE problem? I have tried installing the latest JDK with this: How do I install Java? but it didn't work.

The SIGBUS error in hs_err_pid4159.log is http://pastebin.com/w8YqFJE3

I've also tried this and it didn't work:

alvas@ubi:~$ sudo update-alternatives --config java
There are 2 choices for the alternative java (providing /usr/bin/java).

  Selection    Path                                            Priority   Status
------------------------------------------------------------
* 0            /usr/lib/jvm/java-7-oracle/jre/bin/java          1072      auto mode
  1            /usr/lib/jvm/java-7-openjdk-amd64/jre/bin/java   1071      manual mode
  2            /usr/lib/jvm/java-7-oracle/jre/bin/java          1072      manual mode

Press enter to keep the current choice[*], or type selection number: 2
0

It's not exactly resolving the problem but I've reinstalled eclipse and am using the latest version so now it's working again.

Follow installation instructions on: http://ubuntuhandbook.org/index.php/2014/06/install-latest-eclipse-ubuntu-14-04/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.