0

Okay, let see if I can keep this short and simple.

I switched from deluge-daemon to transmission-daemon a few months ago on my Ubuntu 14.04 server VM. I was doing something totally unrelated when I decided I wanted to reboot (old Windows habit, makes me feel better) While it was rebooting, I noticed the following:

Start-up text showing Deluge trying to Start, then failing and stoping
(source: tuxsrv.com)

I used find to find (sudo find / -name deluge) any file on my system with 'deluge' in the title, nothing comes up. I tried to purge (sudo apt-get purge deluge*) nothing is installed, so not removed.

Can someone shed any light on what be going on? I am super confused.

  • I have voted to close this as off-topic but is also essentially a duplicate of: askubuntu.com/questions/132967/… – Cas Nov 11 '14 at 18:05
  • I disagree with your assessment that this as off-topic/a duplicate. My question has nothing to do with finding deluge in Dash. Second it has nothing to do with uninstalling Deluge. I even noted that Question when searching for an answer. Not one of the provided answers helped me to solve my issue, nor did the link provided to the deluge wiki. – Luis Flores III Nov 11 '14 at 18:40
  • It is to do with uninstalling deluge, you question clearly states that and it would be classed as a bug if it was the package leaving behind files. Furthermore it is up to the user to stop a service if they don't uninstall the program. So this question is of no relevance to any other user and thus is offtopic. – Cas Nov 11 '14 at 22:14
  • 1
    You're using the wrong find. Try -name '*deluge*'. – muru Nov 13 '14 at 3:57
  • definitely neither off-topic nor a duplicate... – Seth Nov 15 '14 at 1:59
2

While writing this Question up, I decided that 'sudo find / -name deluge' wasn't good enough, so I ran sudo find / -name deluge* where I notice that for some reason Deluge had left two startup scripts in /etc/init/, deluged.conf as well as one for deluge web, deluge-web.conf

A quick sudo rm deluged && sudo rm deluge-web took care of it quite nicely.

  • That's because you added that upstart service yourself, it wouldn't uninstall files you created. – Cas Nov 11 '14 at 17:56
  • I'm sorry, but no, I have never added files to /etc/init/ – Luis Flores III Nov 11 '14 at 18:35
  • They were not installed by the deluge package so there is no other way they could be created. – Cas Nov 11 '14 at 22:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.