I 'upgraded' from 12.04 to 14.04 and I'm having a problem .I can't seem to fix with eclipse. Specifically, eclipse crashes... consistently. I've looked over the web for a few days and I can't seem to fix this problem.

I have removed eclipse with autoremove and remove and done a clean and autoclean but that doesn't seem to blow-eclipse away totally and I think that is what I need to do to get it going again... remove and delete all the configuration files... something is incompatible or in the wrong format for the eclipse version that I have now and what I was using under 12.04?

Here's the start of the sad story:

I knew eclipse was going to be a problem when I started it and it complained about the workspace being in-used or not existing... (it did exist and was not in use... and I could find no lock file) After that I kept 'browsing' over to the workplace and eclipse would crash.

So, I did an sudo apt-get install eclipse... and apt-get said it was selecting previously unselected package and acted like it was re-installing eclipse without downloading anything. After that eclipse would start and when I pointed it to my workspace folder, it went to it and opened the projects that I had previously been work on.... but I noticed all the '.c' files had the icon for Geany... HRM... looks like no CDT... so I went to help->install new software.. and ->All Available sites... nothing listed. Also, none of my plugins are listed as available, no SVN, no CDT, no XML modeling, nothing. So, I tried to update the proxy information and it crashes every time. It will also crash if I go into the general section and try to change anything. But to make it easy the following steps will crash every time for me.

Here's how I can reproduce it:

  1. start eclipse
  2. window->preferences
  3. expand General and select Network Connections
  4. Select the HTTP under 'Proxy entries' and then edit.
  5. Change it, or don't and press 'ok' in that dialog box BOOM, dead

Here's what goes into the terminal window after the window disappears from KDE:

# A fatal error has been detected by the Java Runtime Environment:
#  SIGSEGV (0xb) at pc=0xb738ee0e, pid=6516, tid=3076417280
# JRE version: OpenJDK Runtime Environment (7.0_65-b32) (build 1.7.0_65-b32)
# Java VM: OpenJDK Client VM (24.65-b04 mixed mode, sharing linux-x86 )
# Derivative: IcedTea 2.5.3
# Distribution: Ubuntu 14.04 LTS, package 7u71-2.5.3-0ubuntu0.14.04.1
# Problematic frame:
# C  [libgobject-2.0.so.0+0x16e0e]  g_object_get_qdata+0x1e
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
# An error report file with more information is saved as:
# /tmp/hs_err_pid6516.log
# If you would like to submit a bug report, please include
# instructions on how to reproduce the bug and visit:
#   http://icedtea.classpath.org/bugzilla
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
Aborted (core dumped)

I have the crashlog file, and it is quite long, if it'll help I can post it or excerpts from it if needed.

update: It seems anything that changes the workspace or the settings for Eclipse will cause Eclipse to crash. New project... crash. Also, even though I did an apt-get install eclipse-cdt, Eclipse doesn't seem to understand what a .h or .c file is. Nor can I choose a c project from the new project wizard.

  • possible duplicate of How to install Eclipse?
    – MadMike
    Commented Nov 10, 2014 at 16:47
  • I need to stay standardized on the version that is plugged into 14.04 so that there are no version conflicts with the other 14.04 machines that are not having this problem.
    – david1024
    Commented Nov 10, 2014 at 18:32

3 Answers 3


If you are using Eclipse Luna, this will crash when attempting to create a new java project or another type of work.

To solve this (worked in my case), do the following:

  1. Go to System Settings
  2. Go to Application Appearance and open the GTK tab
  3. On GTK Themes, in GTK2 Theme, select another different to oxigen-gtk, like Clearlooks
  4. Apply
  5. Exit and make sure Eclipse is closed
  6. Logout an login again to make some visual changes to take effect
  7. After login, open Eclipse and test.

I'm using Eclipse Luna 4.4.1, Clearlooks as GTK Theme, on Kubuntu 14.04.1 x64 and java version "1.7.0_72".

I hope this help :-)

  • Indeed, Eclipse crashes when I try to create a project. Seems any change to the workspace or configuration settings will make it crash. I have changed the WM settings as you describe and it still crashes. So I changed them back... and it still crashes. This seems to be some sort of configuration file corruption problem.. like maybe eclipse no longer has write access? This is the only machine I did an 'upgrade' on (vice a re-format and re-install). I guess the upgrade from 12LTS to 14LTS just doesn't work.
    – david1024
    Commented Nov 12, 2014 at 19:52

Don't bother with eclipse version that apt-get provides you

Go straight for the official version on the official site. Follow the steps from this this answer.

The advantage installing with apt-get:

  • one single sudo apt-get install eclipse command to install eclipse

The advantage installing your own:

  • You can choose what version of eclipse you want. Be it the latest greatest or something older.
  • You get to choose when you want to update. Updating in the middle of a urgent project isn't fun.
  • Sometimes newer eclipse need more RAM, CPU, HDD space.
  • Eclipse is keeping itself up-to-date if you want. It is also keeping tab of the installed plugins as well. So you don't need apt-get to keep that one updated too.
  • Eclipse will tell's you when there is a new version of itself and gives you a choice to update it now or later.

I've been working about 4 years with Java on eclipse (also Intellij IDEA) on Linux on day job. Using the official version was never a option as there were always plugins I needed to use that only worked with that special version.

Installing eclipse manually might seem cumbersome the first time. But once you've done it it's very easy the next time.

  • I need to stay standardized on the version that is plugged into 14.04 so that there are no version conflicts with the other 14.04 machines that are not having this problem. This is not an acceptable answer for me. Although I suppose it may work for someone else having this problem.... it will still leave a bunch of orphaned configuration files laying around my install as well.
    – david1024
    Commented Nov 10, 2014 at 18:34
  • Ubuntu installs the 'official' version. I'm not sure why you want to bypass apt-get. That causes a lot of problems other problems later when you do want to start migrating everything else. I think the upgrade from 12.04 to 14.04 (BOTH LTS) just doesn't work. Unless I can get something figured out by friday, I'm just going to have to re-install the OS to make sure all the tools are correct... if the Distrubution upgrade screwed this up... what other messups did it make?
    – david1024
    Commented Nov 12, 2014 at 19:56
  • @david1024 I've added some reasons why to install it manually.
    – MadMike
    Commented Nov 13, 2014 at 0:07
  • Mike, I appreciate that you prefer to maintain eclipse outside of what the automated tools do, but having an oddball-configured machine is a problem for me. There are lots of reasons for this, mostly configuration control and the administrative burden of this machine being 'different'.
    – david1024
    Commented Nov 13, 2014 at 16:07

This is caused by a known bug that appears when upgrading from 3.7 to 3.8 of eclipse (which a distribution upgrade from 12.04 to 14.04 effectively does) Also current versions of eclipse (4.4+) will have similar issues, check this bug report:


The work-around is essentially to install the gtk engines and then go into system settings for x windows and de-select the gtk engines... and then relaunch eclipse.

Even though this bug is against 4.4, the same fix worked for me with 3.8.

Thanks for the help!

P.S. Mike, just going off grid with the eclipse version does not fix this, nor is this a variant of 'installing eclipse'. I do not appreciate your spamming this question with unsuitable and plain wrong answers for 'rep-points'.

Not the answer you're looking for? Browse other questions tagged .