1

Two of my computers running Ubuntu randomly ignore the configured keyboard layout and fall back to qwerty.

On one computer the configured layout is "Français" (French), on the other it is a bépo (dvorak-like layout for French). On both computers the layout was selected at installation time in order to make it the default system-wide. On both computers the login screen always uses the right layout. It's only once that the user is logged in that the keyboard starts working as a qwerty

One computer uses LightDM and Unity, the other uses GNOME Display Manager and GNOME 3.8. The problem occurred with Ubuntu 14.04 and is still in 14.10.

So far I tried to erase my ~/.gnome* and ~/.config directories and to reinstall the system, without success. I have also ensured that the session settings were copied in the system settings in the control panel.

Do you have any hint to solve this problem?

Edit: also, even if the layout is incorrect in the session, it is still correct in a terminal opened with ctrl+alt+F1.

0

try running :

sudo dpkg-reconfigure keyboard-configuration

you will see a command-line configuration screen like this (sorry, French version) :

screen capture) :

Use keyboard UP and DOWN to select the correct options, TAB to switch over "OK" or "CANCEL" and ENTER to move to the next screen.

Hope this helps.

|improve this answer|||||
0

This could be a keyboard priority issue. On Unity dash, search for "System settings" then open: System settings > Text Entry. Then use the ^ arrows to move up the layout you want to be the default keyboard layout. Make sure that your preferred keyboard layout is number one on that list. I would also suggest that you also remove all keyboards layout(s) you don’t need/use, use the - and - buttons to add or remove keyboard layouts respectively.

Then next time you restart you systems the changes should take effect.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.