2

I am using an Acer Aspire TimelineX 4820TG notebook with Ubuntu 14.04. Everything is working well except the graphics and when I update my system.

On a new 14.04 64bit installation, the default selected option in proprietary drivers is an open source driver selected for graphics. I have two options there for ATI proprietary drivers, one is with updates and on without it. When I install any of the two proprietary drivers and restart my system, it shows: Your computer is running in low graphics mode. And when I press enter to confirm, it opens up the terminal. I tried the same with drivers directly downloaded from the ATI website, but no help.

Both of my graphic cards remain active and mouse pointer flickers too much. I am searching about this topic since 2 years, but still not able to find a solution. I have tried almost every generic switchable graphics post, but none of them works.

So, my questions are?

  1. How can I make this to work? I don't want an instant switch feature (if not possible). I can switch the cards with a restart. If nothing can be done, I would like to disable the ATI card and continue running the Intel one but with no mouse pointer flickering.

  2. Whenever I update my system using apt-get update and then apt-get upgrade, screen goes blank after a restart and never come back (even if the normal open source graphics driver is installed).

Is there any possibility I can get to work my system with Ubuntu 14.04 close to perfect?

Configuration: 3GB RAM, Mobility Radeon HD 5650 1GB, Core i5-460M

0

Open Terminal (Press Ctrl, Alt and "T" at the same time), then copy-and-paste this in (you will need to paste by right-clicking the Terminal window):

sudo apt-get install fglrx fglrx-core fglrx-amdcccle fglrx-pxpress

Let Terminal do its thing, then repeat with this:

sudo ln -svT /usr/lib /usr/lib64 #Only for Ubuntu 64bits

And finally this:

sudo amdconfig --initial

Restart your computer and see how you go...

  • OK. Let me try this. Will it also give me a menu to switch graphics? – Forthaction Nov 10 '14 at 8:58
  • If this works for you, I'd be tempted to try it on an ATI/ATI laptop I have, which I have never gotten to work with proprietary drivers. – Dan Johansen Nov 10 '14 at 9:25
  • E: Unable to locate package fglrx-core :( Any help? – Forthaction Nov 10 '14 at 9:54
  • Are you still having issues are running the three commands and restarting? I got an error when I did it (I copied the solution someone gave me just the other day), but everything's working fine... In fact, I didn't start to have problems until I switched to the the embedded (Intel) graphics (I had to completely remove the AMD stuff, then re-install it to fix my problems). – Gregory Opera Nov 10 '14 at 11:00
  • I did everything except installing fglrx-core due to an error. Still the same issue, your system is running in low graphics mode. Nothing's working :( I read somewhere that HD 5xxx chips are not supported with fglrx, can this be the case? Also, can I just switch graphic cards with the original Ubuntu installed Xorg graphics driver? fglrx isn't working for me. – Forthaction Nov 11 '14 at 4:14
0

I also have the same graphics card - ATI Radeon HD5650M.

I have installed the package fglrx-updates and am facing no issues whatsoever and can also play games like Left For Dead 2 on Steam with good frame rates.

enter image description here

There is no such thing as HD 5xxx series not being supported by fglrx-updates as mentioned by @forthaction. Try reinstalling the package by following these steps -

sudo apt-get remove --purge fglrx fglrx-amdcccle fglrx-updates fglrx-amdcccle-updates

sudo apt-get install linux-headers-generic

sudo apt-get install fglrx-updates fglrx-amdcccle-updates

sudo aticonfig --adapter=all --initial

Now, reboot the system and run fglrxinfo to see the driver version installed.

If this doesn't work for you, try installing the upstream drivers directly from AMD's website. Instructions for this can be found here.

  • Did not work. Got one window saying "The system is running in low-graphics mode" and just an OK button, which then opens a new window where you get 4 alternatives: Run in low-graphics mode for just one session OR Reconfigure graphics OR Troubleshoot the error OR Exit to console login. I selected the first one and then got to console login. It's an Intel i5-450M (2.4GHz, 3Mb L3 Cache) processor in my Acer Aspire TimelineX 3820TG and think all of the Acer Aspire TimelineX laptops uses Intel processors. Is that why it fails? Is there any specific that work with Intel and the ATI Mobility Radeon? – Pixic Dec 4 '14 at 1:57
  • 1
    My processor is an Intel one too - i3-330M. So I'm sure that it it not the reason. Did you try the upstream drivers? – Rohith Madhavan Dec 4 '14 at 4:01
  • No, I did not, so I will give that a try. Just didn't have the time in the middle of the night. :) – Pixic Dec 4 '14 at 9:07
  • Can't find Mobility Radeon HD 5650 (i.e. "5650") anywhere as supported unless "565v" is the same thing... I wonder if it is really supported. Guess I have to try and find out... – Pixic Dec 8 '14 at 20:54
  • I followed the instructions and executed most of the commands on the page you linked. It seems that the graphics updates a bit better, i.e. not flickering as much as it did before, but it's not as it should be. Also, the temperature is the same if not even hotter, even though I followed the instructions to lower temperature as well. Good help, but would prefer better solution to get it both working fine with the graphics and lower temperature. (Normal temp ~60C and running video ~90C.) – Pixic Dec 8 '14 at 21:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.