0

I've been following a tutorial to install ndiswrapper and have successfully installed that and the drivers for my wireless usb card. As soon as I get to the ifconfig wlan0 up part the terminal writes back:

wlan0: ERROR while getting interface flags: No such device 

If I type ndiswrapper -l, I receive:

bcmwlhigh6 : driver installed device (13b1:003a) present.  

I've searched online and tried to follow many tutorials and solved solutions but nothing has changed this so far. Can someone please go through this with me. I'm brand new to using ubuntu and linux in general so please be patient and explain your steps in detail. I am running the latest version of ubuntu server right now.

  • Please edit your question to add the result of: sudo modprobe ndiswrapper && dmesg | grep ndis Thanks. – chili555 Nov 10 '14 at 14:02
  • sorry for the late reply, I have been at my university all day. The output is: [ 7.615618] ndiswrapper (import:232): unknown symbol: WDFLDR.SYS:'WdfVersionUnbind' [ 7.615635] ndiswrapper (load_sys_files:200): couldn't prepare driver 'bcmwlhigh6' [ 7.615998] ndiswrapper (load_wrap_driver:103): couldn't load driver bcmwlhigh6; check system log for messages from 'loadndisdriver' [ 7.616051] usbcore: registered new interface driver ndiswrapper – ayounis90 Nov 11 '14 at 2:11
  • there was a lot more before but the comment section would not let me post it all. @chili555 – ayounis90 Nov 11 '14 at 2:11
  • Please post it here and let us have the link: paste.ubuntu.com – chili555 Nov 11 '14 at 2:15
  • paste.ubuntu.com/8931592 – ayounis90 Nov 11 '14 at 2:26
1

I don't know where you got the inf file, but it is obviously incorrect. Let's erase it:

sudo ndiswrapper -e bcmwlhigh6

Download this file to your desktop so we can find it: http://downloads.linksys.com/downloads/driver/AE2500xp_WHQL,0.zip Right-click it and select 'Extract Here.' Now do:

cd ~/Desktop/xp
gedit bcmwlhigh5.inf

Use nano or kate or leafpad if you don't have the text editor gedit. Add these lines, around line 170:

[Linksys_AE2500.files.NTamd64]
  AE2500xp64.sys,,,6

Spacing, spelling, punctuation, etc. must be perfect. Proofread carefully, save and close the text editor. Now do:

sudo ndiswrapper -i bcmwlhigh5.inf
sudo depmod -a

Check:

ndiswrapper -l

It should report:

bcmwlhigh5 : driver installed
device (13B1:003A) present

If so, then:

sudo modprobe ndiswrapper

Your wireless should now be working.

To delete all previous drivers and get a fresh start:

sudo rm -rf /etc/ndiswrapper/*

Then start again as above.

NOTE: ndiswrapper is two parts: user space tool that is used to install Windows XP drivers and kernel module to load the Windows XP drivers. Both are called ndiswrapper.

  • I apologize but this is the output. I already tried to install the xp drivers and since they did not work I tried to use the windows vista ones since I saw someone else tried to use the vista ones. – ayounis90 Nov 11 '14 at 3:07
  • paste.ubuntu.com/8932180 @chili555 – ayounis90 Nov 11 '14 at 3:07
  • Vista will never work. I don't see where you erased bcmwlhigh6 first. – chili555 Nov 11 '14 at 3:13
  • I'm not sure how to delete the drivers that are installed, I was just trying to search that up but didn't find anything in the quick search I did online. Do you mind giving me the command to delete both so I may start the process you told me anew? – ayounis90 Nov 11 '14 at 3:15
  • Please see my edit above in a few moments. – chili555 Nov 11 '14 at 3:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.