1

I recently tried using HDA Analyzer to reassign the audio jacks (tried to make my mic jack into a headphone output). I tried changing too many things and now I am unable to get sound out of my headphone jack and don't know what settings to switch back to undo it.

  • The internal speakers work fine I have unmuted everything in Alsamixer
  • I have purged and reinstalled alsa-base multiple times
  • Pavucontrol shows there is sound happening, and the output device is set to "Headphones (Plugged in)," but nothing come out of the headphones.
  • I have tried adding the "options" line to the end of alsa-base.conf, though I don't know what model name to use or where to find one (I've seen lists, but I'd rather not just try different random ones)

Is there some way to reset the Pins in the Analyzer to "default" or in some other way reset the pins

some system specs, just let me know if there's something else I should list:
-Asus K55VD laptop
-Xubuntu 14.04 64bit -aplay -l:

    **** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC270 Analog [ALC270 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

any help is appreciated

1

So I seemed to have fixed it (hopefully permanently). I followed the instructions for installing and updating DKMS (through the instructions found here on the Ubuntu wiki). I had already done this a few days ago, but trying it again with the latest updates must have worked.

sudo apt-get install dkms

Download the correct .deb package from this Launchpad page

Then install it (replace name-of-correct with the actual file name)

sudo dpkg -i name-of-correct.deb
0

Running this commands in a terminal should be ok:

  1. sudo rm /etc/modprobe.d/hda-jack-retask.conf
  2. sudo rm /lib/firmware/hda-jack-retask.fw

Then reboot.

  • unfortunately, neither of those files exist on my system. Might they be elsewhere? – RE3 Nov 10 '14 at 17:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.