0

I installed Unity3d 4.5.5 using wine with Playonlinux. Then I'm trying to import an asset but the store inside the client displays only a grey screen.

According to what is explained here, there should be the chance to import an asset directly from the project window inside Unity. My problem is that when I try to download the asset by logging in i receive back the following error in the console:

Error receiving response from server on url 'https://shawarma.unity3d.com/api/content/download/7677.json?unityversion=4.5.5f1&skip_terms=1': The requested URL returned error: 401 UnityEditor.AsyncHTTPClient:Done(State, Int32)

along with the message popup:

Error building package.
The server was unable to build the package. Please re-import.

The I just noticed that on the top of the inspector appeared the following message:

Network is offline.

This is what I tried so far. I also installed Internet Explorer 8 component on Playonlinux unity3d because I read somewhere that is was needed by the asset store in order to display things but it didn't help.

I also disabled DirectX in the menù but the issue is still here.

Any ideas?

3
  • For the record it's not just you.. answers.unity3d.com/questions/795450/… – demented hedgehog Jan 19 '15 at 22:11
  • He's not using it on linux with wine. I think that is another kind of issue – Leggy7 Jan 21 '15 at 7:36
  • The point I'm trying to make here (in a roundabout sort of way, I'll grant you) is that he gets the same error message as we do and he's not using wine.. which might imply that it's not a Linux related problem? – demented hedgehog Jan 21 '15 at 8:44
1

I read somewhere that if you log in to the asset store from unity installed on a windows machine then it will subsequently work on unix machines (can't find the link but it wasn't my idea). I tried it and it does appear to work. I've just downloaded my first asset from the asset store on unity/wine without getting a 401.

(There's no requirement for it to be a dual booted machine or anything like that.. I borrowed one of my children's friend's laptops).

The problem appears to be that it wants to ask for a username and password the first time you connect from a unity program but can't do that for some reason on linux (the asset store web page stuff doesn't work).

Found it. DustyMonk is the hero in question. See here https://github.com/Unity3D-Wine-Support/Unity3D-on-Wine/issues/5

LATE UPDATE The unity port for linux works really well now. I suggest you try running it natively before running via wine.

3
  • So the asset store windows isn't working yet but you were able to download assets via project windows? I will try to install it on my wife's pc with win8 and will let you know! thanks dude – Leggy7 Jan 26 '15 at 13:00
  • Yes.. once you get past the 401 you can use the approach described by dialytica in that github link I posted above, "You can search assets from assets store by using search box on Project View and you can easily download assets and login without opening assets store view." He's posted a screenshot which might make things clearer. – demented hedgehog Jan 27 '15 at 23:45
  • sorry for the long time it took me to test and reply. It worked after accepting license agreements via the asset store from windows 8 pc. Thank a lot! – Leggy7 Feb 21 '15 at 22:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.